Opal - Wrong Router Time on Boot

So, after various small niggling problems, I reverted to a clean install of 3.206 (in place of the Beta release). This seems to have fixed most of the “niggles” but…I found an old problem resurfaced.

I turn my router off overnight. When I boot in the morning I do not have internet (USB modem).
I diagnosed it back to this problem:

Bascially, the router time fails overnight and doesn’t “sync to browser” when booted in the morning (was 13 hours off this morning). This prevents my Wiregard client connecting automatically.
Interestingly, a second reboot (whether cold or hot) seems to fix the issue.

Last night I turned off Wireguard and the Kill Switch before unplugging the router.
This morning I plugged in and the router time was incorrect and the modem didn’t connect.
A second reboot fixed the problem.

Wireguard, should not have any problem with router’s time. I am sure about this. The problem must be something else.

When the router is off, its time is stored. So next time it boot, it will use that time, until it connect to the Internet and sync with time server.