Open VPN Stopped working, 2.27 Firmware?

 write UDP: Network unreachable (code=128)

Network unreachable, restarting
TCP/UDP: Closing socket
SIGUSR1[soft,network-unreachable] received, process restarting
Restart pause, 5 second(s)

This is what my connection is sayying when i try to connect to a VPN Server ?
I can confirm this has been working fine for 6 months + .
I can confirm I have tested the internet connection and that is working perfectly.
I have done a factory reset loosing all my settings, after inputting all the settings again, the problem still persists.
Could you kindly have a look into this for me as I am now at a loss as what is causing it but have seen the firmware was set to auto update and is now at 2.27.

Did you contact your provdier support?

It seem you can’t access internet. Does it can surf the Internet when stoping openvpn?

I have contacted My VPN Provider Yes They seem to think from the VPN Logs it is something to do with the firewall setup but as I havent changed anything in the firewall I am unable to say if this is the case or not.
Yes I did mention in my first post with the issue I can access the internet if I dont use the VPN and just use the internet from the main router.

But can you get internet without the VPN via the mini router?

Have you tried various ovpn configs?

Have you double checked your user/pass combo?

Yes, I can get the internet If the VPN is not turned on either by the software tick box or the switch on the side of the router to turn off the VPN.
I have tried all the VPN servers from my VPN provider and all seem to do the same thing or after a reeboot will connect to the one it is on, then drops after a very short time and then say’s network unreachable again when trying to connect either with the same server or using a different one.
Yes I have double checked the logon details for the VPN provider.

Which Vpn provider are you using ?

And what model of router are you using ?

Pro Xpn is the VPN
The Router is the GL-AR300M

Have not tried to update to 2.27 yet, but 2.261 is the only firmware I have tried that works with OpenVPN with minimal issues. 2.264 broke it for me. Not sure what was changed in the updates, but revert to 2.261 manually and see if that helps.

This is confirmed for AR300M Lite, MT300A and MT300n V2 from my testing.

(my VPN provider is Private Internet Access)

Hey kimballslice1890 Thanks for the info that could well be the problem im having as it was working fine till a few weeks ago when i started noticing drop offs with the VPN server Can I back date the firmware from 2.27 back to 2.261 with in the firmware part of the GLI Ui and Where would I get a copy of that firmware from ?
Very Much appreciated. :slight_smile:

You can go to the website’s downloads section and manually download the firmware. grab 2.261 for your model and remember where you save the file to (desktop is easiest). Go to the firmware part of the web interface for the router itself and select the file you downloaded. It will manually flash the firmware version. Then reconfigure it and the VPN should work much better. I took my MT300N V2 on vacation and left it connected with the VPN for about 72 hours no issues.

Awesome thanks for the update I have just had a look on the website I belive Im wanting the NAND firmware as it says that at the bottom of my GLi UI but do I want the file in tar or img format to flash the router ? Much appreciated for your help btw you have been a star :slight_smile:

I have not seen any unusual VPN connection issues with 2.27 other than the usual disconnection and failure to reconnect which happens with PIA way too much. Wish there was a permanent fix for that. Every time the router drops the VPN it fails to auto-reconnect no matter what and I have to manually bring the VPN back up or just power the router on/off and let it reset to bring the VPN up again. But this behavior is unchanged from 2.261 or 2.264 so far as I have seen…2.27 drops VPN speeds pretty bad though I’ll probably downgrade as I need more than 3Mbps from the VPN at times.

The reconnect problem is a PIA problem. Have a read here:

As an aside, I recommend reading this:

and consider the wisdom of continuing to use PIA.

So How do i downgrade the firmware tho to 2.261 ?
I can navigate from the AR300M to NAND then do I want to choose - Clean Tor or V1 diretory ?
And then Do I want the file in tar or img file format to flash the router ?


If you upgrade inside a working firmware use the .tar file.
If upgrade using uboot use .img file.

Thanks will give it a shot soon and yea im gonna use the GLi UI to do the upgrade so il use the tar file Much appreciated.

Just in case anyone else was having same or similar issues I can certainly say kimballslice1890 hit the nail on the head with his suggestion of downgrading the firmware as I changed it on saturday Now sunday and still going strong with the VPN server connection.
Had to reboot after the upgrade and restart the devices connected as that caused a small hiccup but since then it has been a solid connection with no drop outs and a fairly good speed :slight_smile: Much appreciated for everyones help getting the issue resolved if there are any other updates il be sure to pop back, Thanks All.

I had similar openvpn issues with 2.27 on MT300N-V2, openvpn client speed dropped from 10Mbits/sec down to 3Mbits/sec, slugguish in gui response, have to reboot on openvpn Client server config change in order to take effect, back to normal with 2.264

1 Like

Has this issue been resolved in the new firmware updates ? im still on 2.26 to scared to upgrade in case it breaks the router again :roll_eyes: