OpenVpn client - do not route all traffic via VPN server

I have MT300N-V2 with the latest firmware. I have an open vpn server where I generated ovpn file and uploaded this into MT300N. VPN works but it routes all the traffic via VPN. I only want to have a VPN tunnel to my openvpn server so I have an access to the openwrt’s shell in MT300N.
How can I do this?

I tried entering this in ovpn but it did not help:
pull-filter ignore "redirect-gateway"
If I use the same ovpn file from my ubuntu box using command ovpn vpn_connection.ovpn, it works and my internet traffic goes via gateway defined before connecting openvpn.

If you use mt300n, it should be v2.x firmware, so you can unticked the option “Force all traffic to VPN”.

Is this in the normal GUI or in the “advanced” luci gui?

On OpenVPN client page, can you see? If not, please take a screenshot.

It is not there. See my screenshots. And the firmware is up to date (v 3.012).

It is v3.x firmware.

Please refer to this thread. Openvpn configuration to avoid the default redirection (all through the VPN) - #6 by kyson-lok

Hello, I have the problem. - ovpn server - subnet of home router (in which is OVPN server ( configured) - subnet of PADAVAN router (OVPN CLIENT - subnet of GL-INET MIFI router (OVPN CLIENT

  • from server subnet ( i can access subnet ( - subnet of PADAVAN router).

  • from - subnet of PADAVAN router i can access subnet.

  • from - subnet of GL-INET MIFI router i can access both subnets and

  • from subnets and I cannot access subnet ( of GL-INET MIFI router.

  • on PADAVAN router has these functions enabled:

Restrict Access from VPN Server Site: No (Site-to-Site), using NAT translation

Obtaining DNS from VPN Server: Replace all existing

Route All Traffic through the VPN interface: Yes

How I can enable same functions as are in PADAVAN router on GL-INET MIFI router? as I understand it’s not working routing because of these functions. Please help me with this. Thank You.

Resolved by myself. If You need some information, can write me.

1 Like