OpenVPN Client issue with Spitz GL-X750 and Flint GL-AX1800

I have an OpenVPN problem that is persistent with both GL Inet routers:
Spitz GL-X750
Flint GL-AX1800

In a few words, I would like to use the above router as an OpenVPN client, but I can open the VPN after that. Unfortunately, I don’t have the internet on the computer connected to them.

I created an OpenVPN server with two different TP-LINK routers and an ASUS .

The OpenVPN server works perfectly with another client; I tested it with iPhone, an OSX computer and a windows computer.

Does someone have any idea? I tried the option to override the DNS setting, in any way, from the GLinet Routers and the computer.

The two Routers Client works perfectly with ExpressVPN, and also, if I create the OpenVPN server with one of them and connect the Client to the other one, I tested the Sprits as Client and the Flint as the server.

Please help!

Try pinging on your computer and, if it is successful, then there is Internet access and it may be a DNS problem.

On the GL.iNet routers, go to the LuCI → Network → Diagnostics page and run the Network Utilities to see if OpenVPN at least works directly on the routers.

I do not work for and I do not have formal association with GL.iNet

Hi, Thanks for your answer.
I tried to ping as well as, no reply from the sites.
I will try to check with LuCI the diagnostic and let you know.