OpenVPN client profiles disappeared, add manually link doesn't work

Hello all!

I had 4 OpenVPN client profiles set up, each with a few config files loaded. Well, this evening I accidentally loaded a config file that had already been loaded, and after doing so, the OpenVPN Client profiles page went wacky, now no longer showing any profiles at all, and when I click “Add Manually”, a green notice comes up that says “Applied!” but nothing else happens.

Anyone have any guidance that doesn’t include factory reset? I did delete the config files and the profile folder of the offending profile, but that hasn’t worked.

Any help is greatly appreciated!

Hello again all! I still haven’t figured this out and still cannot use, view, or modify my router’s OpenVPN Client.

Recapping, after uploading the same ovpn file a 2nd time, the router web gui now no longer shows the profiles and servers I have previously configured (even after deleting the offending profile and its ovpn files), and I’d prefer to restore the OpenVPN Client functionality via a different method than factory reset. :slight_smile:

Anyone have insight on how to do that?

Again, clicking Set Up Now goes to the OpenVPN Client page shown in the earlier screenshot, and when I click “Add Manually”, a green banner momentarily displays “Applied!” (shown in the other earlier screenshot) and then disappears and nothing.

P.S. Yes, I have rebooted the device several times since this condition started and that has not fixed the problem either.


This is a bug that should have already been fixed in lastest snapshot.

vpn profiles got messed up in the router so the API crashes.

You can ssh to the router and delete the vpn profiles manually and check. It should be somewhere in /etc/openvpn

Hello Alzhao! Thank you for your reply!

As shown in this new screenshot, I did proceed to remove the remaining 3 profiles and therefore have cleared the /etc/openvpn/profiles folder of its contents, however, after then rebooting the router and logging back in, I still get the same result when I click “Add Manually”.

The first click on “Add Manually” briefly displays the green banner saying “Applied!”, and additional clicks do nothing at all, leaving me still unable to add or manage OpenVPN client profiles.

Any additional help or guidance is greatly appreciated!!

Update: I went ahead and completely deleted the profiles folder entirely; still same result when I click “Add Manually” as above.

Please execute this command as a workaround:

curl -s | ash

After running this command from hansome, the OpenVPN Client interface page functionality - including my previously configured profiles and servers - was restored.

I did delete all the profiles and will redo the setup of them, mostly because I had deleted the profile folders in a previous attempt to restore functionality.

Thank you!!

1 Like