OpenVPN connected but not used


I´ve a problem with my OpenVPN connection.

In the web GUI I see this status in the attachment…

But the Data is not send via this OpenVPN Server… I checked the public IP address
It works on my Smartphone.

Do I have something else to configure or what is here worng?


Thanks again!

Which vpn service provider are you using?

Which version of firmware are you using? Always upgrade to the newest firmware v2.25 first and re-upload the ovpn files.

The vpn is connected but seems not forwarding data. This can be controlled in the openvpn server. If this is your own server, please find option e.g. allow forwarding data and enable it.

Hi… I have the latest firmware (2.251) installed.


The VPN server is mine (a raspberry) and it works with smartphone or computer at home… So the VPN server is definitely correct configured.


Hmm,any ideas?



It works with your smartphone but it doesn’t mean it will works with the router without problem.

I have my openvpn server in my router and there some options and I have to enable them. Please check if you have the same. We have users who use Raspberry Pi openvpn server without problem.


Ok… I will check the configuration again…


Or maybe some of the users, who use a raspberry as VPN server can post the configuration here? Thanks

Do you have custom DNS configured when the VPN is enabled? Either to public DNS like and or to a private DNS that is only accessible when connected to your VPN server (private meaning the DNS the raspberry is using for its DNS if it’s not using a public one)?

Yes, I push DNS server to the client:

push “dhcp-option DNS”
push “dhcp-option DNS”

Please set the dns directly in the router. push dhcp-option seems not working correctly.

I think the DNS config isn´t the problem, because I can´t ping IP addresses, too.


When I change to protocol type in the OpenWRT Gui under “Interfaces” -> “VPN_CLIENT” to “DHCP client” then I see that data is send (“Data sent” indication at the GL.iNet GUI). But the CPN connection is still not used…

are you using mifi? I think it is because only mifi has a 2.251 firmware. All other models has v2.25 only.

Can you try firmware v2.25? You can download from GL.iNet download center

Yes, I´ve the MiFi with 2.251.

I just did a downgrade to version 2.25. Now it works!! :smiley:

Thanks for the hint.