Openvpn error connectiong to synology router


I have a GL-AR750S, which i use on travels and whch to connect via OpenVPN to my synology router at home.

On my synology SRM i installed the VPNserver plus package and activated openvpn, allowed the vpnuser to access the openvpn server.

I used this in the passed and it workd, but i moved and have a new IP address at home.

I exported the openvpn config and unzipped it, in the file are 2 files VPNConfig.ovpn and a readme file.
I edit the config file and changed VPNConfig.ovpn YOUR_SERVER_IP into my (new) IP address and saved it.

In the router i added in the openvpn client, managed menu i added the changed config file, entered the username and password, a linked it to the profile which it should use when connectiong.
When try t start the openvpn connection i get errors which cannot explain.

I get on connect:
Cannot load CA certificate file [[INLINE]] (no entries were read)
Exiting due to fatal error

and later:

WARNING: No server certificate verification method has been enabled. See How To Guide: Set Up & Configure OpenVPN Client/server VPN | OpenVPN for more info.

NOTE: the current --script-security setting may allow this configuration to call user-defined scripts

OpenSSL: error:0908F066:PEM routines:get_header_and_data:bad end line

Cannot load CA certificate file [[INLINE]] (no entries were read)

Exiting due to fatal error

VPN client failed to connect. This may be because of wrong configuration, unsupported parameters or terminated by the server. Please choose another VPN profile or abort the connection.

When i open the config file the certificate is between , this came from the router when i exported the settings.

As mentioned in the pst it worked (using other IP), i removed all former config and try to upload new ones but is simply does not work.

The VPN itself work, when i connect via a laptop to openvpn i get a connection, only not with my travel router.

Who can help?

It looks like a file format problem. Please check for extra spaces or missing line breaks.
This might help.: openssl - PEM routines:PEM_read_bio:bad end line - Stack Overflow

Can you upload the certificate part of the config file? Please cover the certificate content part

I removed a lot of lines from the certificate in the config and replaced my public IP with an internal one, did not remove anything else, just cut and deleted the middle part of the cert, start and end part is stil original as downloaded from my router.
I attached the conf in a zip to this topic, hope you can help (1.5 KB)

It looks like the problem is in this line.
When I add a carriage return between them, I no longer get the “get_header_and_data:bad end line” error.



Thx, i got it working!