OpenVPN Fails after FW Update

Hi. This is my first post on this forum and I’m looking for help with my GL-AR300M. I just updated its FW to 3.201. Now my OpenVPN connection does not connect. The last line in the system log is

Wed Apr 28 14:17:29 2021 user.notice startvpn: can’t find tun’s ip, local policy failed

The router works fine with VPN turned off. Also other clients can connect to the VPN server just fine.

Any any ideas how to resolve this?

Many thanks.

It can be you should try the 3.105 firmware on AR300M and deactivate the auto update.

What is the vpn server IP in your ovpn file?

Maybe you can configure the ovpn again?

Thanks alzhao.

Nothing has changed in my ovpn file, which worked fine before the FW upgrade. The line for IP is:

remote pppp

This is an IPV4 Address. I noticed in the release notes OpemVPN now supports IPV6 as well. Does that mean the IP address syntax for IPV4 changed?

Thanks again.

Pls check this

Maybe you can change

proto udp


proto udp4

If it is tcp, then

proto tcp


proto tcp4

Thanks alzhao.

I tried changing ‘proto udp’ to ‘proto udp4’ in my ovpn file, but it did not help. I still get the ‘tun’s ip not found’ error.

Any other ideas?

Can you give the details error by giving a screenshot?

Seems not connected to the Internet or dns error.

Not really comfortable sending log data due to security and privacy concerns. Sorry. Here are the two relevant log entries:

Mon May 3 12:35:12 2021 user.notice startvpn: start setting local policy
Mon May 3 12:35:25 2021 user.notice startvpn: can’t find tun’s ip, local policy failed

The Internet connection is OK, because without VPN I can reach the internet through the router.

I don’t think it’s a DNS issue because the VPN Server Address in the ovpn file is a numeric ip address, not a text name that needs DNS resolution. Am I missing something?

Has anyone else had trouble with OpenVPN connection after upgrading to 3.201?

I had the same issue on a Beryl (GL-MT1300), and it was resolved by @alzhao’s suggestion above:

Thanks FMS. I’ve already tried the recommended change to the proto line in the ovpn file. In my case it did not solve the problem.

I also tried downgrading the FW to the previous version. I used the manual upgrade feature in the gui (not the one where you boot into bootloader mode).

The FW format check failed.

Next I think I’ll try reloading the latest FW with the bootloader.