OpenVPN not working (FW: 4.4.6)

I have a Brume 2 2500MT, Slate AX 1800, and Beryl 3000.

The Brume 2 is the OpenVPN server.
The Slate AX and Beryl 3000 are OpenVPN clients.

I have loaded a certificate to the client devices and enabled ‘Allow Remote Access LAN’ on all devices.

All devices show a blue LED icon meaning the VPN is connected and functional, however I cannot ping the LAN subnets of my client devices from a PC behind my server, however I can ping the LAN subnet behind my server device (Brume 2) when my PC is behind a client device.

I have tried loading 4.4.5 firmware on all devices yet nothing fixes the issue.

Is there a way to factory default all my devices to the state shipped by GLiNet, reset any weird LuCI settings to default, and try loading firmware again?

Is there some reason you’re using OVPN & not WireGuard? WG is far easier, faster… at least on my Flint (v4.4.6-release1) & Certa (4.3.7-release7) as peers.

GL GUI → System → Upgrade → Local Upgrade

Hey mate, no reason for OpenVPN. I’ve tried configuring both OpenVPN and WireGuard, and followed the documentation you sent to me however still facing the same issue.

The VPN works, however I cannot ping the LAN subnet from my server to my client side. I can however ping from my client side and hit the LAN subnet behind my server.

I honestly think theres an issue in the interface configuration or routing rules of my Slate and Brume…

I have also reloaded firmware from the web UI and uboot and still bothing works

Right; how do you feel about templating off my confs? Are you comfortable w/ SSH’n into your devices to poke around?

Here’s a primer & suggested resources so you don’t have to keep resetting to stock if something goes awry: