OpenVPN says ExpressVPN is Connected, however it won't let me access Location Specific Apps

OK, New user of GL-AXT1800 and just setting it up. This is my first Post here. I just got this Travel Router and have set it up and I am connected to it with this Laptop as I type this. I have loaded ExpressVPN on it and it says it is connected to a location ‘Chicago’. I can start it and Stop it. So, I tried to run a Location Specific App Sling and it still blocks me. I can run ExpressVPN on the Laptop itself and get to the Sling App just fine. I am still in the ‘Testing Phase’ of this router and trying to understand its’ capabilities. Here is a picture of my Configured ExpressVPN. Any help you can give me will be appreciated. – Thanks

Please check if you are connected by checking your IP:
Does it show your real one or the VPN one?

Some apps are aware about VPN servers and block them.

Thanks for the reply and the link… Yes, it still shows me out of the Country, even though I am connected to the Router with the OpenVPN running on it… And I did run ExpressVPN on the Laptop itself and the IP Address now shows me in the United States and the App runs fine.

So, that is my question and Problem… I would like the router to run ExpressVPN instead of my Devices.

Update: — I just disconnected from ExpressVPN on my Laptop to see what the IP address was exactly. And it still shows me in the U.S. - Chicago to be exact… So, it is working now and I’m confused as I didn’t really do anything, oither than run ExpressVPN on the Laptop and then disconnect it?

Any Ideas?

Update: — I thought it was working, but it is very intermittent. Ip Address changes from U.S. to out of country. Sometimes clearing Cache works, sometimes it doesn’t… Internet works fine connected to the GL router. But the IP address changes randomly with no apparent pattern. I can run a Ookla speedtest and sometimes it will select a server in the U.S. and sometimes it will select one in the West Indies. IP address reads mostly in the West Indies.

Location isn’t really helpful in that case. You should compare plain IPs.
Take your IP when you are not connected to VPN and then when you are connected.

Do they differ? Then it works.
Location detection is based on databases which are pretty often outdated.

Do you use VPN policies on the router?

OK, I took the IP when it was blocking some Apps and not working. VPN on the GL Router

Since this is my first foray into VPN, I don’t even know what “VPN Policies on the Router” means???

Then I took the IP when I started EpressVPN on the Laptop as well as having VPN on the Router. And it worked

Then I stopped Exrpress VPN on the Laptop, using only the VPN on the Router, and it continued to work (Maybe for awhile ??)

Just took another IP – But now my Laptop is now blocking Apps (Not Working)

In that case, it is like I said before: Some IPs will be recognized by the services as VPN. So you have to make sure to use the right VPN servers. There is nothing you can do about it.

What I don’t understand (And I would like to)… Is that I can run ExpressVPN on my Laptop, TV etc and the Apps will not be blocked. However, if I run ExpressVPN on my Travel Router, it doesn’t work consistently. So, I am confused on this.

Do they all use the same servers?

I’ll close this post out, in case anyone comes across it and has the same problem. I bought this GL-AXT1800 router because a lot of Apps were being Geo Blocked, as I am out of the U.S. — It mostly doesn’t work.

I can run a Speedtest and it selects servers in the U.S. - But anything such as Sling is blocked. What I don’t understand, is that the TV here, which is Android can run ExpressVPN and everything works fine and is not blocked. Same goes for my Laptop and Phone…

But if I run ExpressVPN on the Router, everything is Geo Blocked (That wants to be) – I’ve even tried NordVPN and that doesn’t work either.

So, the GLi-Net Routers are worthless to me. Not sure what I could even use these for.