OpenVPN server - can't export config

Hey guys,

I just bought a GL-MT300N-V2 device and I have tried to set up an openVPN server. However, I cannot download/export the config file.

When clicking on export config, I see sometimes an error pop-up “X: warning, no internet” and I am redirected to the home page of the admin panel. I am correctly connected to the router and the router to internet with wifi (I tried and not problem of connection).

I followed step by step as described here:

Step to reproduce:

  • in the admin panel, click on openVPN server
  • click button generate a configuration file
  • click button export file
  • there is an error pop up " X: warning, no internet"
  • I am automatically redirected to home page and no file is downloaded

Do you have any problem related to it? Is there something I can do?



You can try to upgrade to 3.201 firmware version first.

Hi @Riho-shuu,

Thank you for you answer. I upgraded to the latest 3.201 firmware version.

However, I have still the same issue with the same error pop-up. I cant ever start the server anymore when clicking on start, I get the same error.

Can’t believe I am the only one having this issue…

Can you get public ip address via curl -s --connect-timeout 5