OpenVPN Setup - How to?

Hi. I have read the Docs but after I upload an OVPN file or a zip containing all my OVPN files, it doesn’t do anything :frowning: It just stays at “filename.ovpn successfully uploaded” It doesn’t check or import anything after uploading. I refreshed the page and it just says Cannot find any ovpn files etc. click here to select files…

Am I doing something wrong?

My VPN service provider is and I get my OVPN files from here:

See attached screenshot where it stays after uploading. Thanks for your help.

Model: AR300M
Firmware: 2.261

It might just be me (my browser) but those files didn’t download with a .ovpn suffix. If that happens for you as well, try renaming the file to “country.ovpn”.
Or download by right-clicking and “save-as”.

It maybe a browser issue or something. After upload it should display the summary below the box. Otherwise it means there is something wrong.

If browser doesn’t solve the problem please post the content of your ovpn here or upload it here so that others can try.


Thank you guys. Indeed it was the browser. I tried another browser and it successfully imported and asked for my credentials to use.
Do I need to clear any cache of older ovpn files that I uploaded before?

What browser worked and what browser did not work?

IE classic did not work. Chrome worked.