OpenVPN TCP Port 443

Hello Everybody,

I would like to use OpenVPN server on GL-AX1800. I tried to save TCP port 443 but it is impossible. I need this port because in restricted networks, like hotels, it is one possibility to connect to my network at home.

I am not familiar to make any changes regarding the router in its configuration.

I found an information regarding my topic:

But I really have no idea how I could do it.

It would help me to know all necessary steps regarding the change of the port.

I looked in the Advanced Setting and also with WinSCP regarding

vi /etc/lighttpd/conf.d/30-openssl.conf



but both do not exist.

It would be great if someone could tell me the exactly steps to change the port.

Thanks in advance.

To free port 443 on firmware 4.x, run these command:

cp  /etc/nginx/conf.d/gl.conf /etc/gl.conf.bak
sed -i '/443 ssl/d' /etc/nginx/conf.d/gl.conf
/etc/init.d/nginx restart

By the way, the GL.iNet app will not work while Nginx port 443 is off.

Thanks for your help. Unfortunately I got only error messages. I put your command in Putty and confirmed it with the return key. But I got many times the message “no such file or directory”. Therefore what individual steps are necessary to get TCP port 443. Does there exist a chat with the support of Gli net? Thanks in advance.

Please copy and paste it line by line. It seems that there is a Putty bug that doesn’t parse the new line character.

You can also send Private message or by email to

Was there an update to process for setting up Open VPN Server on Port 443? Sometimes this seems to be only port open in highly restrictive environments.

try using 53/udp. you should use vpns on udp anyway.

what do you mean restrictive environments and setting up a server in there?

Hey @hansome Thank you so much!
How do we do if the version is

Use this command on 3.216

rm -f /etc/lighttpd/conf.d/30-openssl.conf
/etc/init.d/lighttpd restart

To get back:

cp /rom/etc/lighttpd/conf.d/30-openssl.conf /etc/lighttpd/conf.d/
/etc/init.d/lighttpd restart

A few months older thread, but I was able to get OpenVPN on my Brume 2 to use TCP/443, but I did it manually after looking through this and other threads here. I successfully used TCP/443 during my trip to Europe to connect to the Brume 2 OpenVPN server from whatever network I was connected to including my cellular WiFi hotspot. and even from a cruise ship’s network.

  1. I replaced the 443 listen port parameters in the /etc/nginx/conf.d/gl.conf file from 443 to 4433 using SSH and the vi text editor.
  2. I rebooted, and after I rebooted I now to used to connect to the SSL GUI.
  3. I changed the OpenVPN server to use Protocol TCP and Port 443.
  4. I started the OpenVPN and it started and is working on TCP/443.

I’m thinking about purchasing a new Flint 2 router, but I hope the procedure is the same if I do get it since the TCP/443 protocol doesn’t seem to be blocked anywhere that I’ve tried so far. And I hope that future firmware updates don’t overwrite this configuration and reset the gl.conf file back to the defaults.

In firmware 4.5, a security page was implemented, enabling users to customize the nginx port other than the standard 80 or 443. Flint 2 leads as the initial model to adopt this version.

1 Like

Thank you for that! I see the Brume 2 has a release candidate for 4.5. Guess I’ll download and install it now.

I updated my Brume 2 to the RC 4.5.

However, since I already had the protocol ‘hack’ setting configured, the upgrade replaced the gl.conf file with the original default SSL 443 port settings so the web GUI was not accessible since the OpenVPN connection started first using the TCP/443 port. Anyway, I manually changed the gl.conf file again to 4433 and rebooted so I could get into the web GUI. I then stopped the OpenVPN server and changed the OpenVPN server back to TCP/1194, and then changed the gl.inet file back to the default SSL 443 and rebooted. After the reboot, I used the GUI settings to change the Security page HTTPS port to 4433, and then changed the OpenVPN server to TCP/443 natively now. SWEET!

1 Like

I need to do the same but I‘m using the LTE/4G router (GL-X750V2)

Is it possible?

Yup, should be possible on all devices.

1 Like