OpenVPN + wakeonlan

I run openvpn server on my Flint (AX1800)router and I want to use WOL while I’m connected to VPN. Unfortunatley I don’t know how to set it up. I’d rather prefer not to set it up through WAN.
I’ve also encountered strange behavior of my set up.

  1. While I’m connected to VPN I cant ping my windows PC but I can take remote control over it.
  2. I’m not able to send WOL directly from my router and it doesnt matter if I’m connected to router through vpn or directly from my home network. Yesterday I was able to do it each time i was connected to router from my home network, and it also worked randomly while i was connected through vpn but it had to be straight after my pc was just turned of and i had to spam it with wol packet. It is worth mentioning that I’am able to wake on lan my pc from my other device that is connected directly to my home network no matter how time passed after I switche off my pc. Today I wasn;t able to do it. Probably because of some settings - I had to reset router to factory settings earlier this morning and set it up from scratch but im pretty sure that I replicated my previous settings. Only thing that could change is that I fixed ip for my windows pc this time.
    My flint router is connected to my internet provider’s router on which i’ve set up just two things: vpn port forwarding and dynamic dns.

Please help,

You can’t.

WOL uses broadcast UDP traffic, which is not routable.
It’s only available on the network you are currently in.

You could SSH into your router and use WOL commands there, like this one:

Thanks. etherwake and lucid-app-wol are consistent in waking up my pc when connected to my router through vpn.