Openwrt don’t allow android's samba server /w unusual ports while stock firmware allow

Hi,

When using TP!ink C2 archer’s stock firmware,
A win10 PC connected to LAN port, /w cifs ports modified to SMB TCP 1445,
NETBIOS UDP 1137, 1138, using freeware “multi port forwarder”

Together with an unroot-ed android, using samba server app “landrive”,
connect thru wifi, /w ports modified above,
were able to share files.
The PC can ping, can FTP into, and enter the samba server app.
The unusual ports are used because of an unroot-ed android (see landrive)
(The PC can also CIFS into another win10, using normal ports)

BUT if that router is changed into an openwrt router,
No matter it is commercial GL inet BrumeW, v3.104 stock firmware (a 19.07.x),
OR DIY D1ink 842 /w latest openwrt snapshot.
The PC can ping, can FTP into, but CANNOT enter the samba server app.
!!! (BUT The PC can STILL CIFS into another win10, using normal ports)

I don’t have a USB lan for android so I cant try phone+LAN yet.
Could there be some restriction between the wifi and the LAN of an openwrt?

Help is appreciated as this is the only problem introduced after I switched into openwrt.
Thanks.

.
.
.
.
.
.
.
.
.
.

^—above is shorter version after I done some test, thx

old title: BrumeW don’t allow samba /w unusals port TCP1445, UDP1137/1138, thx

Hi~

For an unrooted android to act as samba server, and share files to a win10,

I have to use an app called “LAN drive”, which use unusual ports:
SMB TCP 1445, and
NETBIOS UDP 1137, 1138.
(only 3 changes)

Graphically:

Unrooted android ------- router------- win 10 PC.

The PC side need install a freeware “multi port forwarder” for the 3 changes.

Previously I can do so with a TP!ink C2 router,
But recently I changed the router into a BrumeW, v3.104 of stock firmware,
which is a 19.07.

So I cant share files in that way now.
Hope there could be help and that could help others too.

Thanks

additonal info:
The PC can ping successfully the android when using BrumeW.

The PC can even login a FTP server when using BrumeW.

so I think it’s openwrt/BrumeW blocked some ports so it allow ping, allow FTP login, but disallow the modified samba. thanks

further info:
using TP!ink, PC cifs share to PC is OK (using normal ports), PC samba phone is OK (using unusual port, in which PC use “multi port forwarder” and android use “landrive”, using the above 3 ports).

but using a GL inet BrumeW,
PC cifs share to PC is ok (using normal ports),
while PC samba phone is NOT ok (have to use the above 3 ports for landrive as is an unrooted android).

a self flashed D1ink 842 is ok with PC cifs share to PC using normal ports

thanks

latest update:
BOTH the commercial openwrt GL inet BrumeW,
and the self flashed D1ink 842 (lastest snapshot) allow-ed ping, allow-ed FTP (port 2121), also normal CIFS (PC to PC, normal ports), but NOT modified samba (PC to android, above 3 ports).

While a TP1link C2 stock firmware allowed all.

So that should be openwrt’s setting I think.

thanks

ps: in all cases, PC is connected to router’s LAN port, while phone is using wifi.

I’ll try to test what if both are using wifi, thanks.

update:
no joy,
even PC and phone all using wifi, still can ping and FTP into, but not samba /w unusual ports. thx

Is it a SAMBA version problem?

don’t think so, definitely openwrt router blocked the above ports.

because when using TP1ink, PCs by LAN, phone by wifi,
PC-A can ping everyone, can FTP into everyone,
can use normal ports go to PC-B’s cifs.
can EVEN use the above 3 unusual ports to go to phone.

I only changed the router into BrumeW or self flashed openwrt D1ink 842.
PC-A can still ping everyone, FTP into everyone,
can use normal ports go to PC-B’s cifs,
ONLY PC-A cant use phone’s samba.

ps:
when PC-A and PC-B share files, normal ports are used,
only when PC-A and phone, that PC-A have to use multi port forwarder while phone using samba server; and both are using the above 3 unusual ports.

thanks

well,

others say it’s my system 's problem,

others with openwrt say they can access the phone.

let me try later.

thx