Opevpn server routes

Openvpn server changes /etc/openvpn/ovpn/server.ovpn config file. I remove the redirect gateway line but it is back when server is restarted. Where is the script that is overwriting this config? How do I remove the redirect gateway option so when clients connect only the internal network route us pushed?

dont need an option in GUI if there is not one, I can edit the script that is injecting the unwanted PUSH option if I can find it.

You can also add pull-filter ignore redirect-gateway to the client configuration. This is helpful so you can use a config without that line in a Starbucks, so all your browsing is encrypted over the tunnel, and use a config with that line where you are in a secure location and don’t want the throughput loss of going through the tunnel.

@elorimer Hi, thanks, I also needed to add the route for internal subnet. ended up editing
so while there adding the subnet might as well disable the redirect-gateway.

All working.
now looking to fix it so server and client can run as I normally would. not sure why this restriction, probably memory or CPU grunt? Ill find out.
There is a linux box onsite, but head honcho wants it in the router and this is the router given LOL.

Thanks again for the suggestion,.

Thanks for pointing me to that file. That gets regenerated each time the router is rebooted, doesn’t it, from rom/usr/bin/gen_ovpn?

I use my Mango only as a travel router, not a main router, and it works just great for that. I can’t see using it as the main internet router, or really as an openvpn server unless I have a really slow internet connection, like 25/1. Still, I was surprised that the server options seem so limited.