Orange doesen't work on Spitz AX (GL-X3000NR)

I completely understand that this device is in Beta mode, even though you guys sell it already on your website, but honestly, it is a piece of garbage as-it-is now…without any software oversight and extensive testing from your R&D team! I will have to return it, as it it’s completely useless for me. I have a 3 year old Mudi that works better than this 2023 modem, excuse me, I meant that actually works! It is very frustrating…You should stop selling this, until you make sure it is fully functional!


New routers have some software hiccups at the beginning. If you don’t want to deal with that then wait one year for the firmware to mature

I understand that you are frustrated now but as in life - if you wait for everything to be perfect then you will never start anything

Thank you very much for your information.

First of all, I’m very sorry.

It includes mechanisms that are compatible with many Carrier. Orange also has different types of cards,It requires different conditions for each sim card.

Your issue is not the same as andreiB’s: the issue you have is that the sim card cannot be registered.
In this case, you need to report the IMEI of the device to the carrier.(The issue andreiB have is that devices can be connected but there is no network)

For fifth APN issue, we have contacted the chip supplier at the first time and determined the final plan.

Look forward to a good experience next time.

Have a good day!

Hi! Is there a way that I can push/spoof my own IMEI via root or something else??! As this is a software issue not hardware! Thank you.

The Carrier generally use IMEI as an authentication mechanism. But some Carrier will also have other identification information, such as the type of equipment.
So when using a SIM card, it is best to consult the corresponding SIM card Carrier what restrictions are there?


If it’s convenient for you. You can use this firmware to test:

And Use this profile:


I made the update, but still no change.
the same 5 APNs after the update and the solution is the same, remove the last APN and restart the modem.
And every router reboot will break everything back.

Hi andreiB:


The information I have get here is:

This sim card uses the 5th APN to get the IP, so deleting the 5th APN was wrong.

So the profile uses the 5th APN to dial. But there still seems to be issue for you.

I will try later today to check if only CFUN=0 and CFUN=1 will solve the problem.
Maybe deleting the APN wasn’t necessary.
Will be back with an answer.

I did the tests, but no way to keep the 5th APN and make it work.
I tried AT+CFUN=0 then AT+CFUN=1 a few times without removing the last APN, but it never connected.
As soon as I removed the last APN and restarted the modem, everything worked as expected.
If you think of something else I can test, let me know.
I wonder if there is a way or the need to update the modem firmware.

Hi andreiB:


Is the following configuration information displayed?

It cloud upgrade locally:GL.iNet download center

If it is convenient for you, please help to share the equipment with me again.

Hi @lizh
Sorry for such a late reply but I had no time for this earlier.
I don’t have the option for the 5th APN.
If needed you can update the firmware but with condition to keep all the settings.
Thank you!

Thank you very much!

It requires no reserved configuration upgrade, Otherwise, the relevant configuration of orange may not be updated.I will update the firmware to fix it.

Hi @lizh
Thank you!
I have physical access to the router again and it looks like working even after a reboot.
Just the update with no reserved configuration was the solution?
From what I remember it was a betta firmware, will this fix be added to the next release?
Thank you for help.

I wonder if the fix will end on the stable firmware.
I factory reset the device and updated at the last firmware, but still not automatically work with Orange RO for a reason. I expected the fix to end on the stable release in 8 months.

Hi andreiB:
What version of firmware are you using?

The latest firmware using the following configuration should have solved the problem.

1 Like

Thank you!
I forgot to select profile manually. I used autoconnection as for the Vodafone SIM.
So it works now. I will mark your last message as a solution as I think it is more relevant now that the fix is on the release.