Orange doesen't work on Spitz AX (GL-X3000NR)

After my Teltonika RUTX12 broke, I decided to replace it with GL.iNet
I have a Spitz AX (GL-X3000NR) and also a Puli (GL-XE300).
I have two SIMs, one from Orange and one Vodafone.
Both of these SIMs are working as expected with the Puli (GL-XE300) on 4G and same place, but on Spitz AX (GL-X3000NR) only Vodafone is Working. I know that the Vodafone SIM can use 5G and Orange SIM has only 4G, but from what I can see on Spitz AX documentation the 5G modem can handle LTE too.
If I press Auto Connect button the router will set the MMS APN and I don’t have internet access but it looks like connected. When I set the APN for internet it can’t even connect to Orange. I use the same APN on both routers and I changed a lots of settings for Orange connection, but nothing is changing.
Is there anyone who has an idea about how this problem can be solved? I have to specify that I live in Romania.
Spitz AX (GL-X3000NR)

Working with Vodafone SIM:

Screenshot 2023-06-19 234707

Not working With Orange SIM:

I have no idea how to solve this. I tried even to use Modem Manager from Luci, but it looks like the modem is not supported by Modem Manager (Didn’t tried to much).
Thank you!

Have you configured the relevant APN with orange?

Thanks for the answer,
Yes, the same as on the working Puli (GL-XE300).
I also did this on luci a few dozens of times on custom routers till now with this Orange sim successfully, but on older CAT4 and CAT6 modules.

Hi andreiB:

I need your help to share the device with me through the cloud platform,then check and debug.

And the wan port of the device connects to the network cable.


  • The cloud platform account is: ‘gl.inet_support’

It is a bit scarry, to give access to my router even if you are from GL.iNet, but I enabled Good Cloud and gave you access anyway.
I’m back and set the Puli router with Vodafone SIM before this router so you can access it. Now it has the Orange SIM and not working.
Please let me know when you are done with it. Thank you!

andreiB, did you try the Orange SIM on both slots 1 and 2 on Spitz AX?

Yes, I tried both ways. Always only Vodafone works

Could you change the IMEI code from Spitz AX to match your phone IMEI and try again?

Some mobile network operators are sometime fussy about IMEI for different reasons

Thanks for the idea!
I’m no longer at my laptop, but I will try when I get back and will let you know.

It didn’t work. I changed to my phone’s IMEI and after this to the other GL-iNet router( the one that is working with this SIM), but no change.
It is funny that if I use the APN for MMS it is connecting. It looks more like it is on Orange side, but how is it working with the other GL.iNet router?

It configured for the 5th APN to obtain IP.But It should use the first APN.

1 Like

Hi! I really dont get this solution!!! How is this even a solution?! I’m having the same issue with Orange sim card not registering on this 500USD 5G router…!!!

Hi @Marocanos ,
It looks like after I let access to a GL-iNet engineer to my router the problem was solved, but not for long, it lasted till a reboot or a firmware update (I can’t be very sure about this as the first reboot was for an update)
What @lizh did was just to remove the 5th APN but I think she did something more as this is no longer a solution for me.
But using AT commands I managed to make it run two times after this, but as I sent a lots of at commands from the device datasheet, I can’t be sure which one was useful and as I use this router for daily work, I can’t afford to test to much.
What I did is to check the APNs by using AT+CGDCONT?
Resulting in this:

+CGDCONT: 1,"IP","net","",0,0,0,0,,,,,,,,,"",,,,0
+CGDCONT: 2,"IPV4V6","ims","",0,0,0,0,,,,,,,,,"",,,,0
+CGDCONT: 3,"IPV4V6","SOS","",0,0,0,1,,,,,,,,,"",,,,0
+CGDCONT: 4,"IPV4V6","VOWIFIORANGE","",0,0,0,0,,,,,,,,,"",,,,0
+CGDCONT: 5,"IPV4V6","","",0,0,0,0,,,,,,,,,"",,,,0


After this I deleted the last 3 APN by sending AT+CGDCONT=5 , AT+CGDCONT=4 and AT+CGDCONT=3
But nothing solved and if I reboot the router all these APNs are back.
But after I removed the latest 3 APNs I sent more commands from the datasheet like AT+COPS? , AT+CEREG? and AT+CFUN=1,1, but maybe more. Also a reboot was needed as after I sent this commands the 5G module seemed to disappear, but was fixed with a reboot.
If @lizh can’t tell us for sure what should be sent, when I will have a bit of time I will try do do one command at a time and be sure which one made the device to connect.
Also now the device can’t connect to Orange because yesterday it started to work not so good because of local network coverage I guess and I changed the device to use Vodafone sim and rebooted and now it can’t connect to Orange anymore.
I think if you change the Router to use the other SIM slot it will brake everything you did for Orange to work and you have to start again. It means the router will be unable to change automatically between two SIM cards of one is Orange.
It needs a firmware update for sure.

1 Like

Your orange cannot be registered.Some orange requires specific IMEI. You need to replace the IMEI or bind the IMEI to the router at the carrier.

Do you mean that orange can’t reconnect when the routing device restarts?

@lizh , I can’t guarantee about reboot as I had no time to do a better research.
I will try to research a bit more because this can be that it breaks only after firmware update (It happened once, but it was also the first reboot after you fixed everything) or when changing to the other SIM slot that has a Vodafone sim (This happened yesterday and now I can’t connect back to Orange and I have all 5 APNs again).
I can’t do the test right now as I can’t disconnect the internet for another few hours, but I will try to do some tests later today and write back

1 Like

Ok,I get it.


OK, How am I suppose to change the IMEI permanently, via root admin? I do not have the time nor the patience to play “developer” with a router that I have paid almost $500.00!!! Please reply with the AT command or the steps…necessary to make this work. I can use an IMEI from a deactivated 5G phone that I own… Thank you guys for your prompt replies, it is very much appreciated! Regards, M.

I made some tests and these are the steps I have to do to make Orange work, even if I will repeat myself.
For a reason there is an extra APN when I connect to the Orange SIM.
When I send AT+CGDCONT? I get:

+CGDCONT: 1,"IP","net","",0,0,0,0,,,,,,,,,"",,,,0
+CGDCONT: 2,"IPV4V6","ims","",0,0,0,0,,,,,,,,,"",,,,0
+CGDCONT: 3,"IPV4V6","SOS","",0,0,0,1,,,,,,,,,"",,,,0
+CGDCONT: 4,"IPV4V6","VOWIFIORANGE","",0,0,0,0,,,,,,,,,"",,,,0
+CGDCONT: 5,"IPV4V6","","",0,0,0,0,,,,,,,,,"",,,,0

It is clear that the last APN has no value and this doesn’t allow the device to connect properly.
After this I have to delete the last APN by using AT+CGDCONT=5
Next step is to stop the modem using AT+CFUN=0 and after this I have to turn it back on with AT+CFUN=1 no other ways of rebooting the modem are working.
After a minute or two it is connected and working.
It will stay connected until the first reboot or till I change to the other SIM slot. After this the 5th APN is back and I have to repeat everything.
Is there a reason why it can’t do everything automatically as GL-XE300? This way cheaper router can do everything by itself when dealing with exactly the same Orange SIM.
Is there a chance to include a fix in the next firmware release?
At least if it would stay connected after reboot, it won’t be so annoying.
Also, this way I can’t use Auto Switch between the two SIM cards I use and this is a feature I really need as the signal in this area goes crazy from time to time but not in the same time to both these two providers.
I understand that this is a new device I preordered, it has a new modem and there is still some work on the software side, but I really hope that this will be fixed soon as this is not a cheap router. I bought this one to avoid fixing problems if using OpenWRT on custom hardware.
I really like GL-iNet products and I hope this will stay so as I couldn’t find good alternatives in this price range.

1 Like

Thank you for your insight…you’ve shaded more light on this issue than the vendor itself! :))) LOL