Outgoing UDP blocked

I have a AR300M, how can I unblock outgoing UDP traffic? I suspect higher ports are blocked.
Port 53 works of course, but a high port in the 50000s seems to be blocked. Router firmware 2 and 3.

I think it was blocked by your ISP.

No, most definitely not the case. The AR300M is not my normal router, just my travel router.

If you are travelling, the hotel or location you are at has an ISP too. They can be blocking ports. That is what Kyson meant.

Sorry for not being clear. Let me elaborate:

I am testing wireguard from my mac. it access a high UDP port on my server. It works perfectly with my home ISP.
Now I plug my travel AR300M router in front of it and use it as an access point, connect the mac to it. All internet connections work fine. But wireguard from my mac does not work anymore. So I suspect that the AR300M is blocking outgoing UDP packets.

If you change it back to 51820, can it work?

Yes! 51820 works, how did you know? And why does this one work?
Many thanks.

Hello kyson-lok, I have a GL inet ARM300 and I can’t find a way to enable UDP on the device. Does this device support UDP traffic. If yes can you tell me how to enable it?