Override Operator DNS

Hey
I got a cheap SIM to test my VPN configuration before taking my GL-E750 out in the wild.
However, I’ve run into a problem connecting to my VPN server at home.

The operator supplied DNS servers give me a really old IP address for my VPN server.
I just want to override these but configuring Custom DNS Servers only applies to the E750’s DHCP clients and not the E750 itself.
I need the E750 to use a DNS server that works so it can find my home IP to establish the VPN connection.
Currently I am stuck with this crap from Lyca mobile DCHP
root@GL-E750:~# cat /etc/resolv.conf
# Interface modem_1_1_2_4
nameserver 83.137.6.6
nameserver 209.244.0.3

Even dnsmasq gives me a good DNS lookup from 127.0.0.1

Does anyone have a suggestion for overriding these resolvconf entries without hacking around too much?

Is your DNS a local DNS server or public DNS server.
The config of /etc/resolv.conf should works for the router itself not all the clients.

The DNS servers in /etc/resolv.conf are public DNS servers provided by the operator over DHCP.
The operator provided DNS servers are bad to the point of being suspicious.
They give incorrect lookups and I don’t trust them at all.
I need to set the DNS servers for the router itself so it can find my VPN endpoint.
I also want to set the DNS servers for the router itself to ones I trust.

I have been able to apply configuration that precedes the modem DHCP values using
uci set network.modem_1_1.dns=‘8.8.8.8 8.8.4.4’
This config for modem_1_1 ends up in /etc/resolv.conf above the settings for modem_1_1_4 so it works.
However, I would rather not have the DCHP values there at all.

8.8.8.8 8.8.4.4 <<<< in my opinion, you are brave to trust these Try something less big brother!

Please understand that my main objective is not to have “nameserver 83.137.6.6” in resolv.conf on my router at all.
I would really welcome suggestions on how to avoid getting the DHCP provided crap added in the first place.

Can you just modify /etc/resolv.conf manually?

I’m probably totally wrong but how about trying this:
Luci > network > Interfaces > Tethering/Modem > Advanced

and uncheck “use DNS servers advertised by peer”

You might also try setting manual DNS and “overide DNS for all clients” in the GL UI (Under More Settings > Custom DNS Server)

2 Likes

Oh, Yes :slightly_smiling_face:
This is exactly what I was looking for.
The only problem is that Luci is not installed by default on the GL-E750 but it can be added manually as per E750 Mudi freshly unboxed : No Luci.