Packet Loss over Wireguard

I have two GL-MV1000 that act one as wireguard server and the other one as client.
In the last period, when watching movies in streaming connected to the wireguard client, I am experiencing intermittent drops of video quality.
Running Speedtests, I discovered that I have a % of packet loss between 1 and 7.
I imagine this is not normal and might be the cause of the issue.
I also tried to change MTU without any result.
Do you have any advice on how to solve it?
Is there any other way to connect the two MV1000 with a tunnel?
OpenVPN is slower and might not ensure me 4K HDR quality (or am I wrong?).

The GL-MV1000 is capable of good OpenVPN speeds that should be more than enough for 4K streaming. You can just try using OpenVPN.

What are the rated Internet download and upload speeds from your ISP? Some ISP’s provide much higher download speed than the slower upload speed. If so, then streaming traffic going from WireGuard Server back to WireGuard Client will be limited at the upload speed and may result in more packet loss.

I do not work for and I do not have formal association with GL.iNet

Thanks! Will try with openvpn.
Where the server is located, I have FFTH 1000/300 so I guess it is not a problem of internet bandwidth.

If you change wireguard client listen port, restart wireguard server, and connect the client again, will things be better?

Thanks, you mean changing the listening port on the client side, right? On the server side I do not change it I imagine.

Yes, on the client side

I tried to set port 443 on the client side and Speedtest I have run shown still 2.5% packet loss.

What is the packet loss without a WireGuard client?
Could you try to enable NAT offload:

uci set firewall.@defaults[0].flow_offloading='1'
uci set firewall.@defaults[0].flow_offloading_hw='1'
uci commit firewall
/etc/init.d/firewall reload

thanks, I made tests with different devices.
All devices connected to the VPN show packet loss between 0.5 to 7%.
With VPN disconnected, on the other hand, all devices show 0% packet loss.

I will try to do what you suggested, I assume I have to SSH in the MV1000, correct?

sorry for the double post.
As an additional info, I have run a speed test also from a device connected to the MV1000 Wireguard server with the Wireguard application on windows (and not connected to the MV1000 that act as a client).
The result has been the same with 0.7% packet loss (maybe from the MV1000 that act as a client is sightly higher, usually around 2/3%).


Please also change the server port, I’m not sure if it’s MV1000 hardware capability that causing packet loss or the network.

Can you paste part of the speedtest screenshot?

Thanks, I inserted the setting you suggested via SSH.
From a first test from the Speedtest App in my Apple TV, I can see that packet loss went from 5/7% to 0.3%.
That is the same level of packet loss that I have using the Wireguard app on windows on my laptop.
In other words, something is indeed changed!
Which port would you suggest to enter for the Wireguard server?
If I recall correctly, I think that I port-forwarded that port (the one that the server uses).
As for the speedtest screenshot, I made it on the apple tv and I got approx. 230 Mbps Download,(ISP on server side is 1000/300) 34 Mbps Upload (considering that my ISP on client side is 1000/40) with approx 50ms ping.

Since WireGuard is UDP based by default, it’s normal to see “packet loss” since UDP is “best effort” protocol.
Unless it’s a huge loss one, I think it’s still “normal”.

1 Like

Any new port is okay, I doubt the older port is “cached” by the middle of the network device. But that’s just a guess.