Password already set on GL-USB150 out-of-box?

I just received a GL-USB150 from Amazon. I tried connecting to it two different ways from my Linux Mint laptop: plugged into the USB port (wireless networking turned off, wired network turned on) and plugged into a USB charger (wireless on, wired off, SSID “GL-USB150-3f3”, password “goodlife”).

In both cases when I visit 192.168.8.1, I was prompted for an Admin Password.

I also tried 192.168.8.1/index.html and was prompted again for root password, but in a different style (“Powered by LuCI …” at bottom).

I tried using a pin to reset the device. The lights flashed and the network connection dropped, but the operation was the same when I reconnected. Repeated the reset another two times, but I still haven’t seen any different startup panels besides the two above. The manual leads me to believe I should be prompted for language.

What next?

Thanks for your help!

(Discord wouldn’t let me put two images in my first post.)

Follow this guide bellow:

https://docs.gl-inet.com/en/3/troubleshooting/debrick/

Use the latest firmware from here:

https://dl.gl-inet.com/firmware/usb150/testing/

It can happen that for some devices the memory can be corrupted out of the factory. Follow the guide above to overwrite the firmware to make sure everything is as it should be.

Thanks. Very tricky to stab the reset button on the USB150 while plugging it into power! I think I managed once to have it come up with IP 192.168.1.1 instead of 192.168.8.1, but must have messed up the routing. Couldn’t ping 192.168.1.1 (no route to network, IIRC), never mind browsing to http://192.168.1.1.

Going to keep trying… will let you know how it goes!

It is very strange.

If you buy from Amazon it should not comes with password.

When you reset the device, hold the reset for 10 seconds until the LED flash 4 time per second. It must reset. Otherwise cannot understand why.

1 Like

I think my assigned NSA agent must be an apprentice… :wink:

Thanks for the reset tip!

Following the tip from alzhao, I was able to reset the device to factory settings: Plug in to USB port, stab reset button for at least 10 seconds until fast flashing by LED. The unit then came up according to Quick Start manual with a prompt for language. Then I set a password, then used the UI (as per section 5.2 of User Manual) to upload the latest firmware suggested by Johnex.

When firmware upgrade was complete, I removed the GL-USB150 from the laptop port, waited a few seconds, and plugged it in again. This time I was prompted for password, and the password I set above was recognized.

Thanks for the help, Johnex and alzhao!

Amazon sells returns as new all the time.