Password Stop Working After Upgrade GL UI

I did upgrade using .tar file in

Now GL UI doesn’t allow password. Doesn’t allow default password.

Luci allows password. But not GL UI. I reset password in Luci. After, GL UI continues does not allows password, only Luci allows password.

I should test something?

In the past they are a bug like this reported on the deleted bug tracer. It can be this one is still or again open.

In the past it was “solved” by customer, by change password 2 time, one time on normal gl ui and on time on advanced gui.

If you have seen this bug on 3.104 firmware, please add this to the alternate bug tracker:

What do you mean doesn’t all default password?

What do you mean doesn’t all default password?

Sorry. Doesn’t accept default password. So does not accept rue password and also does not reboot to default password on sticker.

Luci accept true password. SSH accept true password. GL UI doesn’t accept true password, also default password.

But I can not access GL UI. This is exactly problem.

Not sure why. Maybe just reset using the reset button and set up again.

Maybe just reset using the reset button and set up again.

Not really possible because wifi is default on. Also it is 2 hours to set up every reset. Really it is best to fix this problem.

Is some setting I can do on CLI?

@alzhao Where is password storage? /etc/passwd only have for root


This seem like isn’t where password exist.

I change passwd with passwd and is working for SSH but continue not working for GL UI.

Could be nand/nor problem? I use nand now, maybe use nor in past.

The UI password is in /etc/config/glconfig

When a password is not setup it should ask you to set up a new password. Can you try a different browser or private tab?

SOLVED! I SSH into router, I edit /etc/config/glconfig to removing password. I reboot (same browser) and now it ask me for password and I am inside GL UI now.

Okay very good, thank you. Now I need solve Tor Not Working - #8 by alzhao

I did exactly what you said and it worked perfectly thank you so much I just removed the long string after password saved it …refresh the page it came up and asked for a new password… but like you I did know the Luci password