PCVR Streaming with GL.iNet Routers: A Call for Community Insights and Mega Thread Creation

Usually I use Airlink instead of Virtual Desktop because it feels smoother with Airlink… maybe I just didn’t configure Virtual Desktop optimally…

Hi @alex_zheng , sure, will try to record it on my next Beat Saber session. I will probably record 2 separate 10mins sessions, one with SQM enabled and one without. Will that be suffice or require longer session? I will try to use Virtual Desktop for this. Any specific wifi bandwidth/channel you want me to use during the sessions? I am currently using 160Mhz bandwidth with channel 60 (DFS).

Everything seems OK. Looking forward for your test result.

Hi @alex_zheng , here you go.

Some basic info:
Router: Beryl AX MT-3000 (stock firmware 4.4.6 stable)
Wifi: 5Ghz (ac/ax), 160 Mhz Bandwitdh, channel 60 (DFS), no other wifi on same channel
Only 1 WLAN client (the Quest headset) and 1 LAN client (the laptop for PCVR) in the network

Logs (both router logs and the ping test logs are included in the zip file)
Virtual Desktop with SQM enabled -
logread_VD_SQM_enabled.zip (65.0 KB)
Virtual Desktop with SQM disabled -
logread_VD_SQM_disabled.zip (66.2 KB)

For the two VD sessions, I played the same 2 songs. Interestingly with VD, the stuttering was not as severe as I expected with SQM disabled. SQM did help but only a little bit, as the stuttering did get slightly lesser with SQM enabled.

It was at this point I noticed my VD was configured with 38Mbps bitrate while my AirLink was configured with dynamic bitrate max 100 Mbps… Not sure if that was the reason the stuttering was not as bad with VD. Wanted to record another session with AirLink but the Quest battery was running out and not enough time today… :sweat_smile:

I rebooted the router between each session, hope it should make the logs cleaner. I also noticed from the VD stats that the latency was around 43ms while on the Beat Saber songs selection screen. Couldn’t peek at it while playing at the same time though…

Not sure if I should redo all these and set a fix bitrate for both VD and AirLink for comparison… but at least there were stuttering occurs in both of the recorded sessions.

1 Like

Hi AlexD,

Firstly, I’d like to know if you’ve turned off the 2.4Ghz radio during your tests, as this can sometimes impact the performance of the 5Ghz radio in terms of system resources. Could you also tell me the power setting of the 5Ghz radio?

Regarding the bitrate, 38Mbps is quite low for a high-quality PCVR experience. If your Virtual Desktop is automatically setting this bitrate when you’ve set it to a maximum of 100Mbps, it suggests that the software is detecting this as the acceptable average speed for streaming your PCVR video content. This could be an indication that there’s an issue with the Beryl’s bandwidth capabilities. Ideally, you should be able to reach 400Mbps using the h264+ codec without problems. This low detected speed is not a good sign.

I always recommend using at least 120Mbps with the HEVC codec for a better experience.

Thank you.

Hi @ASchneiderBR , all other wifi radio has been turned off, only one 5Ghz radio is on with max TX power.

The 38Mbps was probably my own doing last time when I was troubleshooting a non-related issue with another router, not from auto detection. Since I almost never use VD for PCVR, it has been left there alone for quite some time. Yeah, it is quite low and too bad I only noticed it after the recordings were done. EDIT: To clarify, only my AirLink configuration is set to 100Mbps dynamic, my VD is set to 38Mbps.

The codec selection should be on “Auto” and when I had the VD stats overlay up, I saw H264.

It is worrying when 38Mbps is such a low bitrate and shouldn’t put much stress on the network bandwidth but stuttering still occurs, although not that severe.

Perhaps I can redo the recording with higher bitrate, maybe like 400Mbps (h264+) like what you suggested, but I expect the stuttering will get much worse…

Thanks, we will check the log.

Hope you could redo the recording. :grinning:
From the log, it seems that the SQM have some good effert on the stuttering.And did’t see anything wrong.

Zheng, are you really taking picture of your monitor? Greenshot exists. You should install it… ideally via choco.

Let’s focus on technical discussion. Thanks!


I just received my MT3000 to use for VR and am getting stutters every 20-30 seconds, which wasn’t happening with the SFT1200.

Is this something that will be fixed soon?

@alex_zheng I finally got around and give it another test today.

The setup is the same as before, with the exception that for Virtual Desktop, I set it to use H264 codec and maxed out the streaming bitrate, which was 88mbps.
Not sure why mine couldn’t go higher, maybe because my VR headset is the 1st gen of Oculus Quest.
Notes: From the VD performance overlay, it clearly showed it was 5Ghz wifi with 866mbps, and I can see the network latency spiked during those stuttering situation.

I only recorded one session with SQM disabled as I kind of gave up configuring SQM with stock rom, the benefit gained seems negligible.
Depending on the value I set, most of the time it feels about the same as with SQM disabled, maybe in some rare cases are slightly better but I still encountering those big stuttering situation nonetheless.

Here is the exported log from MT-3000 and the ping test (SQM disabled):
MT3000_logs.zip (58.2 KB)
P.S. I looked into the ping test result and was terrified by the latency spike…

Please look into the wifi driver used in the openwrt 23.05 firmware. I remember I read somewhere it is using different (maybe open source?) wifi driver and it maybe could mitigate the bufferbloat to some extend.
So far, from what I’ve tried, openwrt 23.05 firmware with SQM is the only solution that is close enough for a good PCVR streaming experience.


Hello @alex_zheng,

I’m thrilled to report back with an exciting update on my PCVR streaming experience using the Beryl GL-MT3000 router. After obtaining and testing a brand new unit of the Beryl router, the improvement in performance has been nothing short of astonishing!

Key Highlights of My Latest Test:

  • Network Latency: I achieved an impressive latency near 3ms. This is a remarkable improvement over my previous experiences.
  • Streaming Quality: The gameplay was smooth and uninterrupted, with absolutely zero stuttering or freezing.
  • Duration of Play: Contrasting my earlier trials where the router shut down after 10 minutes, this time I managed almost 2 hours of continuous play without any issues.
  • Potential Cause of Previous Issues: It appears that my initial Beryl unit might have had a factory defect. This new unit’s performance starkly contrasts the problems I faced earlier.
  • VR Headset and Settings: For this test, I used the Meta Quest 3 connected to the 5GHz band at 160MHz bandwidth, with a bitrate set to 200Mbps.
  • Firmware and Connection: I’m currently on firmware version 4.4.6, using settings restored from my previous Beryl router. The router was connected directly to my notebook’s USB port, which worked flawlessly.

The performance of this new Beryl unit has genuinely exceeded my expectations, proving to be a game-changer for my PCVR streaming experience. I am now more convinced of the potential and capabilities of this router in a PCVR context.

Here’s a video of me trying it out: VRChat GL-MT3000 test

Additionally, I experimented with an optimization tool called SG TCP Optimizer, which I found at this link. This intuitive Windows program doesn’t require installation and is run as an administrator. It’s designed to tweak and optimize internet connections by adjusting TCP/IP parameters.

In the next few days, I’ll be conducting additional tests to further evaluate the router’s performance. Plus, I’ve recorded a video showcasing the Virtual Desktop statistics during my gameplay. I’ll share this soon for a more detailed perspective of the improvements I’ve observed.

Thank you.


It’s a good news. Have you test 90 framerate? the video shows 72

Hello Alex,

Thank you for your response. Regarding the frame rate, it’s important to clarify that the focus of these tests was primarily on evaluating the networking performance of the router, rather than the gaming performance per se. In this context, the frame rate (FPS) does not significantly influence the outcome of the tests.

The crucial factor in these tests is the bitrate, as it directly relates to the router’s capacity to handle data transmission. For the router, the content of the data (like frame rate) is less relevant compared to the volume and consistency of data it needs to process.

I chose to set the frame rate at 72 FPS intentionally, as I was running the tests on a notebook. This decision was made to avoid overburdening the system and potentially impacting the overall pipeline, which could have interfered with the primary objective of evaluating the router’s networking capabilities. By keeping the frame rate at a moderate level, I ensured that the networking aspect was tested under optimal conditions, without the confounding variable of excessive system load from higher frame rates.

1 Like

Have you changed many settings from default?

I’m having stuttering issues on 4.4.6, wondering if updating to 4.5 will help?

Hello. Not much, really. It is operating in router mode, 5ghz band at max power, 160mhz bandwidth. No VPN or apps running, just the headset connected to it. Network acceleration is turned on. Have you tried the network optimization tool I had provided before? I don’t think the latest beta version would help, but you give it a try, just remember to backup your settings :slight_smile: Thanks.

Hello everyone! I’m sad to inform that the other Beryl I had, also started to restart itself after about 10 mins of PCVR gaming. Is this happening with you as well? Thanks.

Mine does not have the auto restart issue… Having said that, I recalled there were 2 occasions that the wifi connection dropped during the very beginning of the gaming sessions, but once it reconnected, there is no more issue, except the latency issue.

Just to be sure, are you using the power adapter that came with it?

Hello Alex.

Sadly it is not a Wi-Fi radio disconnection but a full restart of the device. It also takes about 3 mins to finish the restart process, indicating there’s something odd happening, that triggered the restart.

I’ve tried with the original power adapter, a 100w PD one and (ideally) connecting to the thunderbolt 4 USB C port of my Alienware notebook (capable of powering on a full 4k monitor just by a single USB cable), so I don’t believe it is a power issue at all.


Hi ASchneiderBR . We have done some test based on your senario. And device works fine,Without any reboot. we also trace the current during the VR test, it’s only reach 1A. We will get the one you returned next monday. we will do some test based on that device.

1 Like