Phone avoiding particular GL-B1300 in mesh

I have a mesh system with 3 GL-B1300s in my house. Main router in the basement, one on the second floor and one on the 3rd floor. I have ethernet pulled in my house so the mesh was setup wirelessly and then ethernet was plugged into the WAN port of the slave nodes for ethernet backhaul. I have noticed that whenever I am on the 3rd floor in the same room as the Convexa B I can watch my phone signal go up and down as if it’s jumping between nodes. Sometimes disconnecting from WiFi entirely and going to LTE. I have a pixel 3a. Anything I can try?

Do you use ethernet backhaul on both second floor and 3rd floor b1300?

Yes, that’s correct… ethernet backhaul with both.

I’m not 100% sure but I may have solved my problem. I started thinking if there was anything I had customized. Then I thought about how I’m using pihole to block ads. There’s an advanced setting on the main router I had set to advertise the pihole DNS server (DHCP-Options). I removed the customization and it seems to be working as it should now.

1 Like

Sadly it turns out this was not the fix