Pi hole on raspberry pi W zero

I am setup pi hole on raspberry pi W zero and have setup B1300 DNS Forwarding to under Network>DHCP and DNS …within Luci.

B1300 has a static local IP set for Raspberry pi (

But I still don’t see it working. I have setup my custom upstream DNS to NextDNS but NextDNS is detecting that I’m using my ISP DNS.

Any suggestion?

Can you not use luci and just use B1300’s default custom dns function and set the dns to Pi?

That doesn’t work, have tried setting to which is static IP of Pi Hole. Confirmed that static IP is assigned and accessible but DNS isn’t working.

If you use cusomt DNS in gl-inet firmware and force DNS pointing to the Pi, the pi will need to use DoH or DoT to be able to make DNS requests or it will be stuck in loop.

If you are using LuCi and it is not working then that may be down to gl-inet customisations.

A simpler option to test is to set the Pi’s IP address in the client’s WiFi config directly before trying to make it work dynamically.

But why are you using next DNS and pi-hole together? Could you maybe explain a little more what you have and what you are trying to achieve…