PIA WireGuard Issue

I have been having issues trying to connect my Slate AX to PIA WireGuard. I was able to get it to work via a workaround (that I don’t remember how I did) when first starting to beta test; however, I feel that the developers should know about this issue so that it could be fixed to perform the same way that any of the other products work. I have an original Slate, Shadow, Brume-W and Opal. They all connect to PIA fine. They are all on 3.212 vs the Slate AX which is on 4.0.1 beta2 so that could be the issue.

Since PIA does not provide an easy way to download a WireGuard configuration file, I connect all of my devices via the GL.iNet app. With the Slate AX, I get the following in the log:

Thu Jul 21 09:13:25 2022 user.notice wireguard-debug: USER=root ifname=wgclient ACTION=REKEY-TIMEOUT SHLVL=2 HOME=/ HOTPLUG_TYPE=wireguard LOGNAME=root DEVICENAME= TERM=linux SUBSYSTEM=wireguard PATH=/usr/sbin:/usr/bin:/sbin:/bin PWD=/
Thu Jul 21 09:13:30 2022 user.notice wireguard-debug: USER=root ifname=wgclient ACTION=REKEY-TIMEOUT SHLVL=2 HOME=/ HOTPLUG_TYPE=wireguard LOGNAME=root DEVICENAME= TERM=linux SUBSYSTEM=wireguard PATH=/usr/sbin:/usr/bin:/sbin:/bin PWD=/
Thu Jul 21 09:13:36 2022 user.notice wireguard-debug: USER=root ifname=wgclient ACTION=REKEY-TIMEOUT SHLVL=2 HOME=/ HOTPLUG_TYPE=wireguard LOGNAME=root DEVICENAME= TERM=linux SUBSYSTEM=wireguard PATH=/usr/sbin:/usr/bin:/sbin:/bin PWD=/

And it continues on and on.

It doesn’t look like there is much to decipher from that. Has anyone else had any issues with PIA?

Thanks!

Could you please try to do follow steps, thanks.

  1. Your phone connect to your Slate AX’s WiFi, open the glinet app,
  2. Plugins → VPN Clinet → Profile of WireGuard Client → PIA VPN → VPN Location, click a server to connect

Hi, Btw, may i know when the surshark will be available since its has been waiting long a ago. Thanks!

It is almost done. I just think how to tell users the Surfshark key will expiry every 7 days.

You mean every week of the usage, we need to log in again?

Yes.
Is this acceptable? I’m also trying to figure out how to make it less of a hassle.

For time being it’s acceptable but in long run, i don’t think so because it will be hassle as each of 7 days we need to log in again.

However, when it available? So we can try it out as beta version while at the same time your end can make an improvement of the app as well.

Hi Leo. That’s how I’ve always tried to connect to PIA. I just tried again. Here is a screenshot of my log:

1 Like

I just send you a Message. There is no useful information in the log, and it is better that I can remote access to your device.

1 Like