Pixel 7 and SlateAX - Pixel7 will disconnect and reconnect from network in loop

Pixel 7 and SlateAX (4.0.1 and 4.1b3) - Pixel 7 Wifi will disconnect and reconnect in loop.
Pixel can connect fine to TPlink router and other networks (MT1300).
The SlateAX seems to be disconnecting the device over and over (every second)

I upload logs to pastebin for better format Pixel 7 AXT1800 - Pastebin.com

MT1300, firmware 4.1 beta 1 – works fine, no disconnect/reconnects

I saw that you have repeater configured on the router. It may be a problem that repeatger is trying to scan and connect.

So please disconnect repeater, remove saved ssids and test again.

I should have worded my post better.

The SlateAX repeater mode is working great. The SlateAX never loses WWAN .

The pixel 7, when I try to connect to the SlateAX network, it will connect but then repeatedly disconnect/reconnect to the network.

The SlateAX does not like the Pixel 7.

Maybe try changing the encryption?

In the log it just say disconnect.

some more info you can add:
encryption type (wpa3?)
are you using same antenna (5ghz) for wwan and ap and different encryption? (never has worked unless openwrt has changed)

I have seen wpa3 behave like this and the only solution was to connect by bssid insead of ssid

Yes, I’m using the 5ghz as WAN and AP, but I’ve never had an issue until this phone.

I’m using standard config for WiFi.

I have a similar problem when using 5ghz as WAN and AP (not using DFS channels).
I have a Xiaomi Poco F3 and everytime I connect it to 5ghz I have the following on log:

daemon.notice wpa_supplicant[2797]: wlan-sta0: Unknown event 62

Sometimes the phone lose connection and then reconnects.
Two days ago I bought a Xiaomi 360 Home Security Camera 2k Pro and it completely refuse to connect to 5Ghz if using repeater. Nothing useful on log for the camera, in fact looking at the log it seems connected (normal pairwise key handshake completed and DHCPACK).

Hmm and 802.1w 802.11w is set to optional here right or disabled? (Both settings is fine aslong its not forced)

If its on, maybe try turn this off and see if it keeps connected, you see this in the luci wireless settings.

Theres maybe two things to might check:

The dhcp range being requested is correct and not over the range?

Another issue could be in the mixed wpa3/wpa2 sae cipher some devices still don’t like this for some odd reason, then wpa2 works.

Maybe theres also some relevant kernel log information for this unknown event, I did a quick google but couldn’t really find a reason for this than only stumping on a crash log for another device on the openwrt forums, technically everything could have happened there.


I notice you use channel 149, it depends on your country but for example in my country the netherlands 5g can be a little dramatic, I readed somewhere we can only use the lowest segment of 5g or the radar detection kicks devices off, so I keep mine on the lowest band of 5G.

149 should be the US version.

In EU version the router will not use 149. This was an issue but fixed by firmware update.

1 Like

I think I found the issue, but I’m still testing.

I have a Firewalla Blue+, it acts as a drop in gateway, where it spoofs the ARP.
With the Firewalla unplugged, my Pixel 7 seems to stay connected to the SlateAX.

I will continue testing.