Please Help Beryl Gl-MT1300 doesn't read my Huawei E3372 dongle

Hello Everybody
I have bought a new Beryl Gl-MT1300 router. I am thinking of connecting to the internet through Huawei E337 dongle. The router does support this Usb and also I have checked if kmod-usb-net-cdc-ether and usb-modeswitch packages are installed and they are installed in my router (Using the Huawei E3372 Hi-Link LTE Dongle with OpenWRT – Protyposis). In the start-up manual, I read the router doesn’t read the USB for the first time and after the second restart the CSL auto set up will pop up, which is not happening at all in my case (Internet - GL.iNet Docs). I have tried to restart the router many times I have updated the router with the Luci web interface. The router has a problem on 2.4gh with authentication problem, I can’t log in with my pc but only with my android phone and if the authenticity problem occurs I have to restart my android and then I am straight logged into wifi. If I connect the dongle to the PC I am online which is working absolutely fine, please help me resolve this USB dongle reading issue as long I don’t want to return the router to the seller many thanks and have a nice day everyone.

When I connect the Dongle it keeps showing me connect to the Tethering but the auto setup doesn’t show up. When I connect to tethering eth1 it’s showing me I am connected but in browser i don’t have any internet.

Have updated latest firmware (GL.iNet download center) still no connection.

When i made network diagnostic through Luci it says ping : bad address ‘

Huawei E3372 should work as tethering and easy to set up.

The problem is that E3372 also use as IP address. So you can change your router’s IP to or others, then setup tethering.

Yes mate thats the problem, have changed the router and dongle Ips and everything is working absolutely fine thank you for help.