Port forwarding fails but DMZ doesn't

I have convexa gl-b1300 running latest firmware: 3.203.

I cannot get the port forward to work to expose a web-server to the internet. But if I use DMZ, then the web server works.

So, if I setup a port forward for port 80 to the internal web-server device, external http requests to my IP address get ‘connection refused’.

I have changed uhttpd and lighttpd to run on different ports than port 80. So the router’s web services are not sitting on port 80 from what I can see.

However, if instead of using port-forwards, I turn on the DMZ to direct all traffic from the outside to the machine running the web-server, the http requests to port 80 succeed.

Is there something wrong with the current firmware that it doesn’t forward port 80 correctly? I see another question quite similar to mine here, un-answered: Firewall DMZ vs Port Forwards


Freaking hell, so annoying. I think the configuration changes only work after rebooting the router.

Once I rebooted the router, the configuration change took affect and the port was then open.

However, the weird thing is, turning DMZ on and off does NOT require a reboot. But configuring a port forward DOES require a reboot…

I think it maybe because you used 80 port. If you use other port it should be OK.

Nah, I tried other ports as well. It seems it’s any port, needs a reboot.

I ended up configuring the port forward via the cgi-bin/luci interface. I had been trying the port forwards via the gl-inet Vue web-ui. However, none of the port forwards worked on the vue interface. (I tried forwarding ports other than 80 on the Vue interface. Didn’t work.) The thing I didn’t try on the Vue interface, was rebooting after I had setup the port forward. So maybe it would have worked as well, if I had rebooted the router.

Anyway… :frowning: