Port forwarding in repeater mode

I just bought a GL-MT300N-V2 (upgraded to v3.102)
ISSUE: Port forwarding not happening in REPEATER mode.

This is the setup:

             [ internet ]
[, wifi)   GL-MT300N-V2]
    (MT300 working in mode REPEATER, since
     ROUTER-MOVISTAR is far and can not wire
  them both together. Excellent signal though)
   [, ethernet)  RASPBERRY ]
    (MT300 and berry are ethernet wired)  

This is the MT300 CONFIGURATION:

-Under the “Port forwards” section:

  Name    Int.IP        Ext.Ports  Int.Ports  Protocol  Status
  ssh_pi  44100      22         TCP/UDP   Enabled 

-Under the “Open ports on router” section:

  Name        Port  Protocol Status
  ssh_for_pi  22    TCP/UDP  Enabled

With all this said, when sitting from a wireless PC ( and ssh to works fine.
However, when from a wifi PC ( i try to ssh to (hopping the MT300 will forward that to, it DOES NOT work.

Is there any chance to ssh access the raspberry from a pc outside the MT300 subnet?
Any help with this will be very appreciated!

Try to remove open port rule and keep only the rules for port forwarding