Port forwarding not working on GL-B1300 after the 4.x firmware upgrade

I have been using my Raspberry Pi as a Wireguard server for years without any issue.
After upgrading my router to firmware version 4.3.7, my client devices can no longer connect.

I have tried the following without success:

  1. Hard reset router with Uboot. Installed firmware version 4.3.7.
  2. Wiped Raspberry Pi boot drive and performed a fresh OS installation.
  3. Assigned a static IP to my Raspberry Pi.
  4. Set up a Wireguard server on Raspberry Pi using PiVPN.
  5. Forwarded port 51820 on my Raspberry Pi’s IP address using the router’s web interface.

My network is setup as follows:
Comcast Modem (bridge mode) → GL-B1300 (router mode) → switch → Raspberry Pi (Wireguard server)

My Raspberry Pi has been assigned a static IP of
I am using Cloudflare for DNS (,

Here is my port forward configuration:

The only change I have introduced to my setup within the last several months has been updating the router’s firmware, so I am assuming that’s where the problem must lie.

The built-in Wireguard server on the router appears to work just fine, however I would prefer to continue using my Raspberry Pi.

Please export log

Here are my logs:
logread.zip (24.9 KB)

I checked the debug info, and nothing special.
Please ensure the Raspberry Pi gateway is B1300 so traffic can get back originated from port forward.

The Raspberry Pi is connected to a switch plugged directly into my router. I have also verified that it’s using the assigned static IP.

As I mentioned in my post, I haven’t changed anything about my setup other than upgrading the router’s firmware. This setup was operational immediately before the upgrade.

Can you type the command in RaspberryPi terminal

ip route
pi@raspberrypi:~ $ ip route
default via dev eth0 proto dhcp src metric 202 dev wg0 proto kernel scope link src dev docker0 proto kernel scope link src linkdown dev eth0 proto dhcp scope link src metric 202 
pi@raspberrypi:~ $ 

I ran out of ideas. My b1300 4.3.7 port forward for wireguard works fine.

I’m not too sure either. I thought I might see some improvement after a fresh install on both the router and Pi, but unfortunately things are still the same.

I’ve been running this exact setup for nearly 5 years, so it’s a real head scratcher.