Possible Repeater (WISP) issue - GL-MT300N-V2 vs. Mikrotik AP/routers


This is just for Your information :slight_smile: and is absolutely NOT a complaint - love Your routers and the OpenVPN implementation.

The last couple of weeks i have been looking into which travel router to choose for the upcomming summer holiday.

I have been testing (amongst others):
GL-MT300N-V2 - firmware 2.27
GL-AR750 - firmware 2.27

The problem is, that the small GL-MT300N-V2 is unable to connect to my Mikrotik APs. I have tried 3 diffrent models (hAP lite, WAP ac and a RB2011UiAS-2HnD-IN) - have too many routers laying around :slight_smile:

Testing was done the following way(using newest GL.iNet firmware 2.27 and RouterOS 6.41.3 on the Mikrotiks):

On the Mikrotik router:

reset the mikrotik routers/ap’s to factory default.
ran quickset using winbox - Set mode to β€œHome AP” - set WIfi password, using WPA2(aes ccm), set Wifi channel to 6 (have also tried channel 1 and 11 and β€œauto”), 20Mhz channel width and set Country to β€œDenmark”

On the GL-MT300N-V2:

reset GL-MT300N-V2 to Factory defaults
ran initial setup and tried to connect to the mikrotik router, using Repeater/WISP mode.

Seems the GL-MT300N-V2 is not able to create the connection to the Mikrotik router, it just hangs, not getting an IP.

have tried the EXACT same setup with the GL-AR750 - And on that router everything works perfectly

have tried the GL-MT300N-V2 on other accesspoints (ubiquiti AP AC PRO, using the 2G radio) and on a couple of TP-Link routers. WISP mode works perfectly on these APs/routers as well.

So this only seems to consern GL-MT300N-V2 vs. Mikrotik

Have You heard of this issue before ?

Problem is a lot of Hotels/bars/restaurants have Mikrotik gear - so it would be nice if someone had a solution for this problem on the GL-MT300N-V2 :slight_smile:


thanks for the information. I don’t tested Mikrotik before.

I will check if we can buy this brand here.

Thank You alzhao.

i just got the GL-B1300 router today, and can report that it also works perfectly connecting to Microtik :slight_smile:

Thanks. I think Qualcomm chipset works better with various AP.

Yes there definitely is something strange going on with the GL-MT300N-V2 connecting to Mikrotik AP’s.

Just tried a GL-AR300M-Lite, and it also works very well, connecting to the mikrotiks.

So maybe You are right, there is a problem with the drivers for the Mediatek chipset in the GL-MT300N-V2 - It could also be a Mikrotik problem (they also have their own problems :slight_smile: .

So to sum up

GL-AR750 β†’ Mikrotik = OK
GL-B1300 β†’ Mikrotik = OK
GL-AR300M-Lite β†’ Mikrotik = OK
GL-MT300N-V2 β†’ Mikrotik = NOT OK

So i Guess I’ll be taking the AR750 and GL-AR300M-Lite (as backup) with me on holliday this year :-).

Going to Greece and a lot of hotels down there are useing mikrotik equipment.

Thanks. Please let me know the result.