I have an AR300M router it is plugged into my ISP provided router which in turn is plugged in to my telco provided modem. I would like to bypass the ISP’s router and plug the AR300M directly into the modem.

Q1) My ISP uses PPPoA encapsulation. The only similar option on the AR300M is PPPoE. Does this mean that the AR300M is not compatible with the ISP’s service or can these protocols be mixed? If I can’t use a PPPoE connection then are then any other options to do what I want?

Q2) I can’t find an answer to the following. If I go into the admin panel for the AR300M and select ‘New Connection’ what happens? Is the old connection deleted or will it hold the information for more than one connection at a time?


Hi, there are some info about PPPoA at openwrt https://wiki.openwrt.org/doc/uci/network#protocol_pppoa_ppp_over_atm_aal5

First you need to install ppp-mod-pppoa, then you can go to advanced settings (luci) to set things up.

For your 2nd question. If you click New connection, you will be able to set up one of the four methods: cable, repeater, modem and tethering. 4 methods can exist together. For cable, there are DHCP, PPPoE and Static. You only can select one method for cable connection.


Thank you for your reply.

Q2 can be considered as answered .

Q1 not so though. I can’t install ppp-mod-pppoa as I get the following error:

Collected errors:

  • satisfy_dependencies_for: Cannot satisfy the following dependencies for ppp-mod-pppoa:
  • kernel (= 3.18.27-1-39e4d2534c6186c91983d226e664f0c3) *     kernel (= 3.18.27-1-39e4d2534c6186c91983d226e664f0c3) *
  • opkg_install_cmd: Cannot install package ppp-mod-pppoa. `

Opkg is fully updated but no other kernel is shown as available and I have no idea where to get one from.

My feeling is that I had better just stay as I am as I would hate to lose the connectivity I have already and I easily know enough about this subject to break things, but not always enough to fix them again!

Correction to the above.

I just connected directly to my modem using a pppoe connection and it works perfectly! Don’t kow why, but it does so that is that problem solved for me as well.



Please try v2.264 from gl-inet.com/firmware/testing