[PPPoE] CHAP authentication failed

Hello everyone!

I’m having problems using PPPoE on OpenWRT.

My device is a brand new Flint 2 (GL-MT6000)

Every time I have to use PPPoE on OpenWRT, it is not a good time, unfortunately.

This time, the problem seems to be with the authentication, even when sometimes it does connect successfully, but looks like the ISP drops the connection with authentication failed messages.

When I use my Xiaomi Router or my Linux Mint desktop, the PPPoE connects perfectly.

Some info below for analysis:

[Not Working] TCPDump on OpenWRT:


[Not Working] PPPoE Logs with debug enabled on OpenWRT:


[Working] TCPDump on Linux Mint Desktop:

It seems the pppoe server dictates ipv6, so please enable ipv6.

Yep, that was it.

Thanks @hansome

BTW, Where did you saw in the logs IPv6 being mandatory?

I’ve totally missed that.

From the second log:

Sat Dec  2 12:40:10 2023 daemon.debug pppd[18076]: Script /lib/netifd/ppp-up started (pid 18467)
Sat Dec  2 12:40:10 2023 daemon.debug pppd[18076]: rcvd [IPV6CP ConfAck id=0x2 <addr fe80::0200:0000:0000:0000>]
Sat Dec  2 12:40:10 2023 daemon.err pppd[18076]: sif6addr: ioctl(SIOCSIFADDR): Permission denied (line 3011)
Sat Dec  2 12:40:10 2023 daemon.warn pppd[18076]: sif6addr failed

it wanted to configure an IPv6 address of “fe80::0200:0000:0000:0000” but failed.
I think it should also work if /lib/netifd/ppp-up is modified to block ipv6 settings.