PPPoE connection fails

I bought a Flint router and I trying to connect it via PPPoE with my old ISP router in bridge mode, but the connection fails.

I tried the PPPoE without the Flint router, setting up the PPPoE connection directly in windows with the router in bridge mode and it worked.

I don’t know why with the router fails.


please post the relevant logs (should be system)

Here you have, thanks!

logread.tar (119.5 KB)

Hmmm, I don’t see any specific log entries that would lead me to some issue.
You are sure that all credentials and setting are correct?

100% sure, and I’m using only the glinet UI, in this case the ISP is movistar so:
vlan id 6

Hm, in that case I am running out of idea. Troubleshooting PPPoE is some kind of impossible because the logs are not really verbose.

@hansome Any idea?

1 Like

Just in case, I need to change something more since LuCI interface or in GliNet UI to make it work?

Can you goto LuCi → Network → Interfaces → Devices

Choose your device (pppoe-secondwan for me), select “configure” and enable “Enable promiscuous mode”

This worked for me (BT in UK)

1 Like

According to this log:

Mon Jan 29 16:25:25 2024 daemon.warn pppd[26467]: Timeout waiting for PADO packets
Mon Jan 29 16:25:25 2024 daemon.err pppd[26467]: Unable to complete PPPoE Discovery
Mon Jan 29 16:25:25 2024 daemon.info pppd[26467]: Exit.

Most likely it’s the wrong vlan id.
Where do you set vlan id 6 for Windows?
Please try to remove vlan id on glinet UI.

You’re right! I left the vlan id setting blank, and I cloned the mac address of the windows that was able to connect and it worked. Thank you, appreciate your help!