Problem connecting to VPN with MT300n-v2


I’m trying to setup Mullvad VPN on MT300n-v2 but Mullvad does not have ovpn files to download.

They have Mullvad config files to set up on linux, these are:







I have looked at these in notepad and they seem to contain most of the information that is in a general ovpn file for other VPN’s.

I don’t have a template for what works for a ovpn file for the MT300.

Could alzhao or someone help me create a ovpn file, or would I be better asking Mullvad to create one?


Is there a way to manually add all the VPN details into the router without using a ovpn file?

I am not an expert to us. But if you send me all your info I can try.

I assume that the best way is to ask Mullvad to provide a Linux ovpn file. This is what they should do.

Hi there,

I thought it’s a good idea to document the solution for other users with the same problem.

I do have an MT300n-V2 as well, but I guess it will work for other GL Inet products as well.

I had a chat with the Mullvad support facing the same problem, and they replied fast and with a solution to the problem.

All you have to do is go to Account | Mullvad choose Android as your Platform, ignore the instructions on the right side as they seem to be for Android mobile phone/tablet devices.

Enter your Mullvad Account number, and you can leave the Standard Port selection or pick a Port of your choice and then download the Android configuration which is a single .ovpn file that for the MT300N-V2 is compatible as is.

Just upload it via the Router UI and enter your Mullvad Account Number for username and “m” for the password when you are asked for it. The rest is self-explanatory, pick the options/config you want in the Router UI and press connect.

Since both, GL Inet products and Mullvad seems to be a popular option for many users I suggested Mullvad get in touch with GL Inet so you can add the process to your documentation and list of compatible VPN providers and Mullvad can add some instructions specific to GL Inet products to their website.

Hope I could help.

Thanks for providing a great product.


Hi alzhao, turns out Mullvad do have an ovpn file under the android section but I’m having problems with that.

Also having problems with password, seems the router is unable to retain my password so I have to do the 10 second refresh to access the router each time, also the logout button does not work but the reboot button does work, also when I disable the enable server and apply, it keeps trying to connect.

Hi esportagency,

I have tried the method you describe using the android ovpn file but get error:

OpenVpn is connecting …
Last log RESOLVE: Cannot resolve host address: (Try again)
RESOLVE: Cannot resolve host address: (Try again)
Could not determine IPv4/IPv6 protocol
SIGUSR1[soft,init_instance] received, process restarting
Restart pause, 80 second(s)


So I would like to know what your doing right and what I’m doing wrong.

Hi rocksalt,

RESOLVE: Cannot resolve host address: (Try again)

It sounds like either a problem with the specific Mullvad server you chose not being available at the point you tried to connect to it or a problem with the internet connection that the MT300N-V2 is connected to. I tried to connect to the SE server after reading your post and it works fine over here.

Did you try to download the Android config with another server chosen, like their NL server f.e.? I am also using a custom DNS to prevent DNS leaks, you could try entering the Google DNS ( Primary ) for testing purpose if your ISP’s DNS servers are unable to resolve the host address.

You can change/add custom DNS servers if you click on the Globe in the Router UI and then in the row where it says “Internet Status” you will find a button called “DNS”.

Also, my device is on Firmware version V2.264. Just to make sure we both use the same Firmware version.

You said, “seems the router is unable to retain my password so I have to do the 10 second refresh to access the router each time, also the logout button does not work but the reboot button does work”.

Mine doesn’t do that at all, maybe try a factory reset of the MT300N-V2 as this seems to be a problem with your device, but I am sure alzhao will be able to help you out better here if there is a problem with the router itself.

Hi esportagency,

Yes I downloaded the Android config ovpn file for mutiple servers.

After updating firmware I started getting conflicts with my ISP router.

Finally had it connected/working for 5 minutes and tested DNS leaks, it was leaking so changed DNS to, then started getting same error - Cannot resolve host address.

Checked DNS again and it had reset back to default.

You might be right, just a problem with this device.

I have lost count of the factory resets i have done, as I need to do that to log in as it does not remember the password.


Thanks for your input, I’m glad it works for you.