Problem whith MUDI using Mullvad

Hi to all. I need your help/
There is a GL-E750C6 device, after unpacking it was updated to the latest firmware from of.the site.
The problem is that it does not allow you to add a VPN, namely mullvad. I tried both through the modem admin panel and through the application.
Through the android application, the result is as follows :

When creating a config file by the site of Mulvad gives something like this config -

PrivateKey = aA7pRomG6JLsPYwU+85yt3KZskNtSu13aiMNbNqXXXX=
Address =,fc00:bbbb:bbbb:bb01::5:29c8/128

PublicKey = TNrdH73p6h2EfeXxUiLOCOWHcjmjoslLxZptZpIXXXXU=
AllowedIPs =,::0/0
Endpoint =

And,when adding it by hand, nothing works((

I’m trying to figure out where to dig… the account mulvad itself works exactly, when installing a native application on the phone, everything is fine. But it won’t start on the modem. I tried the guide on the manufacturer’s website, it doesn’t work((

When i try to add mulvad

Please provide the phone model, app version, and MUDi’s firmware version.
Does the admin panel work? Do you have a screenshot of the error and log?
By the way, it’s not recommended to paste the key of your Mulvad config file in a public forum.

hello,thank you for the answer.
I try mobile app on Android (Redmi5c) and on iOS ( Iphone 12 pro) - the result is the same.
App version for Android 2.1.0 (141) , for iOS - latest from the AppStore (I can’t see for sure right now).
MUDIs firmware - Current Version 3.216,Compile Time 2023-03-21 17:34:45, Last Update unavailable.
Admin panel work on PC, screenshot of the error on phone I have attached above ( there is only the word “error” on it, without code and explanations), screenshot from Admin panel here

It was not real my key))

And after 20 sec

Please tell me where I can view the log?

The logs on the router can be viewed using the command logread after logging in via SSH. there are no logs in the App to get the VPN profile section for now.

Can’t I pull the configuration files even after entering your Mullvad account on the latest version of the app? Or can I pull the configuration files but it won’t run?
The app pulls the configuration files to the phone first and sends it to the router when the user runs it. The pulling configuration files section has nothing to do with the router. If you can’t pull the configuration files even with the App, please check your phone’s network status.

My advice, based on my own experience, is to go to the Mullvad site and generate your own configuration file (wireguard in my case) from the site. This file can be opened using an editor, and the content placed in the manual configuration tool/tab from the router (wireguard client configuration).