Problem with using config backup on other Router same model

passwd is the standard command to change it

Hi Jeff this only changes the root password, but NOT the password of the UI

except LuCI (LuCI usese root password)

So maybe its the only way to paste the hash of the password in glconfig?!

The admin hash is based on a salt which could only be generated on the original router. So you cannot back up the hash and use it on a new router. But there is an workaround of this and I will send you via pm.

@alzhao

We too are experiencing the exact same issue. After configuring the first GL-AR300M to our liking, we created a configuration backup through LuCI, expecting to deploy that configuration to the additional GL-AR300M units. As @pseffect described at the top of this thread, we are unable to login to the GL user interface, though we can log into the LuCI interface.

Would you be so kind as to share the workaround with me as well?

OK. Sent to you via pm

Workaround is testet and works fine! :smiley:

Please send me the workaround as well. I’m having the same issue with a GL-AR750S.
Thanks!

HI Alzhao, can you send me this via PM?

sent to you via pm. pls check

Hey Alzhao, I too cannot log into the AR750s UI interface after a restore. Could you please send the workaround to me? I have over 100 routers and do not want to have to manually config each. Thanks!

I have sent it to you.

I’m looking for the work-around as well if someone is willing to share it with me. Thank you

Edit: I should mention I’m using a GL-AR750S-EXT (Slate)

Hello @alzhao, can you send me your workaround via PM too, pls?

I will send to you via private message.

Hello @alzhao, can you send me your workaround via PM as well?

ok I think I figured this out I am good thank you, I can generate the the sha256 digest now.

Hello @alzhao, can you send me your workaround via PM as well?

I have several AR750S. This article and another helped me to create a workaround for the admin password not working, if the backup config is applied to another router of the same model.

  1. Create the backup of the source router.
  2. In the backup file, edit /etc/config/glconfig
  3. Find section: config service ‘general’
  4. Under that section delete lines:
    option language ‘EN’
    option password ‘blahblahblah’
  5. Save the file and update the archive.
  6. Restore the backup config to the other routers.
  7. Connect to 192.168.8.1 and set the language and admin password. All other settings should be intact
3 Likes

Can you send me your workaround too? We have built a standard config and would like to have a standard password as well. Thank you!