Public WIFI sign-on page

My beryl router has been working great for my trip so far.

Unfortunately, This new hotel requires a sign on page to connect.

If I sign-on normally directly to the wifi, it takes me to the sign-on page.

But if I connect through the router using repeater mode, the sign-on page errors.

What will I need to do?


Hi there,

Could you tell more about the error?

If I think its just a error on their website it might be some kind of detection.

A very common issue could be that you have to turn off rebind protection.

from what I have found on the forums you could try to mac clone a other device like your phone this way they are less aware of you using a router.

See here

there is also a opkg I believe who can handle captive portals its worth a try.

See here the package should be called gl-portal-detect but it may or may not exist since ive not checked if its compiled in the repository, seeing this issue inside the github issue tracker it might not be there on every platform.



Turning off the rebind was able to get me to that public wifi page.

Would I need to mac clone then?

Thank your for your help.

If it works you should be fine :+1:

Only if it suddenly stops working then they might have blocked your routers mac address, I think it depends on your preference, if you visit alot of different hotels maybe its better to use the mac address clone.

1 Like

Can you get me started on how to do mac cloning? I will also YouTube. Thanks

Sure!, Its quite easy to configurate:

Your phone device is using a unique mac address and your router is using a unique mac address they are usually thight on your hardware.

If a hotel hotspot blocks your router mac address they figured out on basis of the routers mac address that it was a router.

Gl-inet has a option, if you login on your routers web interface and go to settings there should be a tab for mac cloning, the only thing you have to do is change this mac address into the mac address of your phone, basicly you let your hotel hotspot think your phone is connected while in fact it is your router, you find the mac address in your phone settings or from your router if the client is connected.

In case you are using a device with only luci:

depending on the version of OpenWrt you can change the mac address on your wireless interface via the interface tab, on old versions its inside the interface itself, on newer openwrt versions there should be a tab called devices basicly it does the same as the gl-inet option.

1 Like

Thanks so much for your consistency. I somehow accidentally was able to get the mac cloning to work.

I first log into the public wifi with the phone. Then I switched on airplane mode so that it does not switch to data. At that point, I was able to connect to the router ssid. From there, it automatically switched over to mac binding that is not the default which I assume the other one belongs to the phone. Turning off the rebind solved this use.

Thanks so much! It would have been etchy if I could not use my wifi camera to monitor my room.

1 Like