[Puli GL-XE3000] Slow 4G & 5G data speed

Mobile data speeds on my new router, Puli GL-XE3000 (Spitz GL-X3000 with a battery), are well below what is expected.

I’m in line of sight to one of my carrier’s 4G & 5G masts (LTE, 5G NR SA & NSA).

While my phone achieves 110Mbps download and 60Mbps upload, my router, on the same bands and with the same carrier, only gets 5Mbps download and 2Mbps upload.

Cells Info:

Band 3
ul_bandwidth 15M
dl_bandwidth 15M
RSRP -106 (Fair)
RSSI -70 (Excellent)
RSRQ -16 (Poor)
SINR 13 (Excellent)

Band 78
dl_bandwidth 40M
RSRP -102 (Good)
RSRQ -11 (Excellent)
SINR 16 (Excellent)

This is not a SIM or carrier fault, as the SIM has worked in several other devices with expected speeds, and my carrier confirmed that my data speed isn’t being throttled when in my router.

Using speedtest.net, the download speed will quickly hit 200Mbps, but then start dropping rapidly, down to 5Mbps.

Similarly, speed.cloudflare.com measures 6Mbps download and 2Mbps up, but with the occasional spike to 100+Mbps on download tests.

What I’ve tried:

  • TTL changed to 65 (this allows the speedtest to hit 200Mbps before dropping), then 64
  • Full reset
  • Connected to the router by WiFi and Ethernet
  • SIM cards from three providers, with similar results
  • Changed APN, as directed by my carrier
  • Connected to other masts
  • Enabled Band Masking and tried various options
  • Changed IMEI (copied from my old iPhone, Pixel, Samsung, Nokia).
  • Restarts

I’ve put the SIM in my old Huawei 4G router, which gets speedtest results around 60 down and 30 up. In my old phones the download speed reaches 90Mbps down, and around 40 up.

The router will only connect to LTE and 5G NSA bands, and not 5G SA. I’ve tried forcing it to 5G SA, but it won’t connect and displays ‘SIM not registered’.

The router prefers to connect to LTE band 3 which is 3G/4G, and provides more reliable and faster speed than 5G NSA band n78.

I’ve been trying to solve this for nine hours and I can’t think of what else to do. Suggestions welcome!


This is the information displayed under Cells Info for SIM 2 (another carrier):

Band 3
ul_bandwidth 20M
dl_bandwidth 20M
RSRP -100 (Excellent)
RSSI -66 (Excellent)
RSRQ -13 (Fair)
SINR 17 (Excellent)

Band 78
dl_bandwidth 40M
RSRP -101 (Good)
RSRQ -11 (Excellent)
SINR 15 (Excellent)

This SIM in my Pixel 8 Pro gets 194Mpbs download and 78 upload. In the router, it’s 7 down and 4 up.

Note: This issue persists whether a VPN is connected or not. On the latest factory reset I have not installed a VPN profile, and the LTE & 5G connection speeds have not changed.

Something abnormal with these results! Have you tried to upgrade to latest beta firmware it maybe a bug in your current installed version ? Did you try to change the MTU value?

No beta firmware available at the moment. I tried changing MTU, but with no success.
Bizarrely, SIM 2 download speed has now increased to 80Mbps, though no change in upload. I haven’t touched any settings. Can’t see any reason for that in logs.

Well inexplicably, I turned the router back on this morning and it’s decided to work. I’m getting 307Mbps down on SIM 2, but only 6Mbps up. I’d expected upload to be a bit faster, but maybe it’ll fix itself later…

Connection with SIM 1 is still extremely poor.

The signal seems very good.

Can you check the speed test server is the closest one?

I’m in London, about 10mi/16km from the nearest speedtest server. All the other servers are within 20mi. I tried testing with servers in Ireland and the Netherlands, with similar speed results and higher ping (as expected).

However, upload speeds are still far slower than any of my phones, with my Pixel 4 achieving 37Mbps and the router only 6Mbps.
With the SIM in a Pixel 8 Pro, upload is 82Mbps (download now around 200Mbps).

Is there anything I can do with Puli to improve things? At the moment it seems easier to use an old phone as a hotspot/router.

Hello, can you share the device to the cloud platform according to the documentation prompts, and send me a private message with mac and password, and we will check the problem remotely
Technical Support via GoodCloud.zip (158.7 KB)