Puli - How to change (cellular) network provider?

When using a Swiss SIM-card (payed roaming option active) in France, the Puli gets no connection to any network using autosetup.
When I change to manual setup, I get connected somehow, but there‘s no internet available („offline“).

There are different network providers available here n France. Some seem to work with the SIM, some don‘t.
Is there a way to manually choose which one the Puli should connect to?

On a iPhone there was the same issue, when the provider was chosen automatically. Manually selecting a network provider, solved the „no internet“ issue.
So maybe doing the same on Puli could help…?

But I can‘t find a setting how to change the network provider.

For my sim, the provider gave me the value to set in APN under Manual Setup.

I have the APN settings.
They are the same everywhere, in any country.
They do not change according to available local network providers.

But the local network providers change by area.

And I need to be able to define which local provider the Pulli should connect to.

@alzhao
Is there no way to chose one specific network provider with Puli? Instead of having the device chose one automatically?
As you can do with an iPhone when disabling automatic choice (see screenshot).

I have never done that. I can send you a manual of AT command to explore.