Puli. How to use OpenVPN provided DNS?

Hello everyone, I'm very excited with my new Puli router. It is a huge improvement over my previous device. Just WOW. However I'm having a problem and could not find the solution anywhere.

I'm using Cellular/4G to connect to the internet. I've setup an OpenVPN to my home Server (I've used this VPN Server for years with different clients so it is working). I can reach my home network by IP addresses but the problem is the DNS is still using "DNS from Cellular" and I can't seem to change it. So I cannot reach my home network by DNS names defined in my home DNS server.

What I have tried so far:

Using the latest openwrt-xe300-4.0 firmware.

The docs tell me I should change the the Network, DNS setting to "Allow VPN tunnels to prefer their own DNS" however the setting is not there. Am I missing something? It only shows DNS Rebinding and Override DNS for all clients.

The OpenVPN Client Logs show that the correct DNS server is passed to the client. I can also find it in /tmp/resolv.conf.d/resolv.conf.ovpn and /tmp/dnsmasq.d/resolv.vpn is also passing to that file.

However the Network DNS settings say: DNS from Cellular

I can reach my home DNS correctly with "dig @ some-hostname"

In some posts some people mention some scripts to use, but I thought I check in here first if I'm missing something obvious. If I need to install a script, which one should I install exactly?

Obviously I could set a custom DNS IP but then I would have to remove it every time I switch off the VPN which isn't the way it should work.

Any help very much appreciated!

Thanks!! Richard

Just for information I may have solved this myself. I kept trying and here is what happened.

First I added a "WiFi Repeater" so I had both Cellular and Repeater with the Repeater at the higher priority. When I went to the DNS settings, I was shocked to still see that it was using the Cellular DNS.

I gave up and set the manual DNS to my VPN DNS Server which obviously worked.

However the magic happened when I changed it back to Automatic. It no longer said it was using "Cellular DNS". I tried it this way and now the DNS seems to work.

I'm pretty sure there is a bug somewhere here but for now I'm crossing my fingers and hoping it stays working.

So you have to toggle the settings of DNS to make it work correctly? Then seems a problem.