PULI/SPITZ (XE3000/X3000) Google Fi Compatibility Fail

I have spent some time looking around the forum to see if anyone else is having an issue using the PULI/SPITZ with Google Fi. Apparently, there are documented issues…

I have three Google Fi Accounts and I have tried swapping SIM Cards between them (Data/Voice vs Data Only) and this did not help. I have also tried changing the IMEI to use one from a 5G Hotspot Modem which DOES work with Fi (Netgear Nighthawk M6 Pro). Still no luck!

Curiously, I have TWO MUDI devices (V1 and V2) which BOTH work fine with these Google Fi SIMs. …and, as mentioned, my Netgear 5G hotspot works flawlessly as well!

What I REALLY wanted was a 5G MUDI, but short of that, it appears your X3000 with the onboard battery ($500!) SHOULD hold me over. 5G, OpenVPN, Battery, Portable (sort of)… Its significantly bigger and more bulky but at least is has an onboard battery. But unfortunately the XE3000 (and I expect the X3000) DOES NOT work with Google Fi.

…all I’m looking for hear is a portable 5G router with onboard OpenVPN. Unfortunately your MUDI is only 4G and now ($500 dollars later) it appears the PULI/SPITZ doesn’t work properly with Google Fi!

I did notice that the required Google Fi APN info (“h2g2”) is not being stored/recalled properly from profiles. Maybe the firmware (4.4.4) is simply ignoring the APN info?

  • Running Current Firmware (4.4.4)
  • Swapping between other Google Fi SIM Cards did not work (voice/data vs voice only)
  • Changing IMEI (using one from another OFFLINE 5G Motorola Hotspot) did not work either
  • Profiles don’t seem to preserve/recall APN Info (“h2g2”) as they should

If we can’t get this issue resolved in very short order I will be requesting an RMA.

Even better, “Where is a 5G MUDI?”

If you need to assign a custom APN, you need to create a new profile and assign it to the SIM slot.

You may also need to update your cellular modem firmware.

I own an X3000 but do not own an XE3000. I cannot really help any more that this unfortunately. Best of luck getting this one sorted.

I am guessing a modem update may help here.
I have the solution linked and outlined in a post here.

Thanks guys,

  • Yes, we need a firmware update! …and I AM running the latest firmware 4.4.4. I even re-downloaded/installed it. No Change. The modem is useless to me until this compatibility issue gets solved.

  • I believe the XE3000 (Puli) is simply a X3000 (Spitz) with an added battery. I would expect the compatibility issues (& firmware) to be virtually identical.

  • Yes, I tried making a profile and saving it. But the APN does not appear to be stored in the saved profile as when I recall it, its not there and doesn’t get reloaded. Even when I just set it up directly (and specify the APN for the “current” config), the APN I set doesn’t seem to survive a reboot…

Surely, GL.Inet should be able to fix this in short order!

This is a firmware update for the cellular modem in the router, not the router its self.
There is a different process to update the modem firmware, and router firmware will not update the modem.

This link is to the latest firmware dated 02/01/2024. You will have to SSH to the router to apply this update. The links mentioned above have step by step directions.

Thanks for clearing that up. I understand the difference!

Too bad they can’t enable some function in the router firmware to update the modem firmware…

Upgrading the modem firmware solved the 5G connectivity issue. Thank you!

However, my VPN (OpenVPN) still appears to be a bit wonky. It always seems to connect (automatically) back to my router at home (Watchguard), and I can ping a couple of hosts on my internal network, but drive mapping seems to be an issue (“Net use” by IP address).

If I disconnect my WiFi and reconnect it seems to get better. I will obviously need to do more testing. The primary issue here is I want to be able to use this router/vpn on the road with my FireTV stick so I need it to automatically connect it to my home network (via VPN) and I won’t have any good tools to mess with the router (via FireTV). I simply want the router to auto connect vi VPN and then drop my clients right into my home network. It needs to be automatic, reliable, and transparent…

Note that my MUDI’s (both V1 and V2) work completely as required for this. However, unfortunately they do not support 5G. I am looking forward to a much more portable package in the long run (5G MUDI)…