PureVPN didn't work with GL.iNet?

my mt300n-v2 can’t establish a vpn connection with PureVPN (openVPN). I have the latest firmware but the .ovpn files didn’t work for me. any idea?

I may have your answer:
use tcp
udp to purevpn openvpn servers only listen at port 53
they assume alll their customers using the internet would never be redirecting that udp port. sadly they are wrong.

so do you think they might allow connectivity over anther port for udp…nope.

4 Likes

If @rp201rp 's suggestion solved your problem it should be fine.

Otherwise pls give the error message for analysis.

Does PureVPN use separately password for vpn?

1st gen of there vpn client files put all files in a zip file and they imported just fine with gl-inet when it asks for username password. 2nd gen config files have .ovpn all in one and import fine into gl-inet also asks for usrname and password and works fine.

I got same experience, but didn’t know the technical details why tcp ovpn only is working while udp didn’t on purevpn.

Seems your explanation is correct, because some isp force redirecting the dns traffic on dst port 53 to filter/block certain domain.

Nice info bro👍

np. glad to help out. sorry to hear ya went through what I went through. worked through my phone hotspot then not through my internet. hours of trouble shooting think that the server is down or dns errors. then getting on chat with purevpn support and go what? only port 53. they sell add on products to their vpn that do client configured port redirection. asked them If I could buy it for em and allow them to use it. they diddn’t take that too well. lol

1 Like

Hi, I have tried using TCP but still not working, here are some error messages I get

What a coincidence, never though you’re him and open this thread :laughing:.

I think you should accept rp201rp as the solution since i’ve explained you the technical detail in the community.

In summary purevpn is not working for telko* isp because their traffic redirection rule resulting both tcp and udp ovpn not working, for other isp tcp should be working, this explain why i can successfully connect the tcp and you’re not.

try adding
route-nopull
to .ovpn

I found using the android client configs work better than the linux config files with gl-inet import. just a matter of preference. hardly any difference.
.ovpn over .conf

According to the documention, it’ll prevent default route being pushed by ovpn server right, which i believe resulting no default route overriding on client routing table CMIIW?

But it’s worth to try as long as it’s working :slightly_smiling_face:.

Btw bro, did you try it on telkom indihome ISP network, the giant isp from INA? Which this guy currently using.

Thanks bro, by adding “route-nopull” to the .ovpn files solved the problem… :+1:

2 Likes

Wow magic, how can you explain this technically @rp201rp ? I though it will just connect and ignore the vpn route.

not sure if I can answer that correctly cause I started using it about a year ago and can’t remember for sure. I may have used ‘cannon engineering’ (just shoot every config change you can at the problem) but here it goes…
had routing problems and the gl-inet or vpn-policy-routing is already there to handle the route. since there are mulitple vpn gateways you want to rely on the client routing rather that the enherited routing couse it’s not your default gateway for all traffic. disabling just allow the software to work as expected. remeber, this is a router not a client machine.
best guess.

Correct. Unless you set up some other way to route outbound traffic through the VPN, there’s no default routing pushing everything via the VPN.

Cheers.