PureVPN not Working on GL-AR300M

PureVPN is not working on GL-AR300M router. Whenever I try to connect I get a message (see screenshots in next two post)

I have tried various configuration files from their website, including the linux one here: https://s3-us-west-1.amazonaws.com/heartbleed/linux/linux-files.zip and they all result in similar messages.

Any idea on how to resolve this?

This is the message after waiting a few minutes:

This is the message when first trying to connect to a server. Seems like it’s an issue with certificates but I don’t know how to resolve:

Is there no known fix for this? I have bought a subscription to PureVPN based on the below thread saying it was tested but it does not work for me.


Hi, can you try v2.241 from GL.iNet download center ?

Upgrade to v2.241 does not fix the problem. I have also tried a full reset.

UPDATE: Working now with TCP but not UDP.

Not sure if this is still an issue, but here is what I did and it work without issue:

I have a MT300A and have a PureVPN account. They have Howto’s for a number of routers, but not openwrt. I went to their DD-WRT howto (https://support.purevpn.com/openvpn-script-method-for-dd-wrt), and downloaded their OpenVPN files. What I got was a zip with the ca.crt, Wdc.key, and folders of ovpn file (TCP and UDP). I simply uploaded this zip in the basic OpenVPN GUI, entered my username and password, and it just worked. I have been using UDP, but have not tried TCP.

@mobile: it just looks as if the server is down, which isn’t uncommon with Pure!

@kawayana: ditto

Not sure why UDP doesn’t work. Looks not like server down.

PureVPN works very good when you are not in China. Once I get to Beijing is not working using my AR300M. It works on my phone and on my PC using L2TP protocol but on the router it is not working.

Any ideas how to fix this ? I am still in Beijing for another week so any idea you may have, I will try it :-D.

Pure is cheap and nasty but I tested and it works no problem, UDP and TCP (uk server).

Well, I have tried all the servers in the list and it is still not working :-D. So I am kind of left out and i would like to still be able to use it. What is found weird is that it was working in Taiwan very good and once got I got here nothing works. I imagine is something about ports or routing it ?

ok this is just my 5 cent,but here is what i gather so far from learning openVPN

  1. its best to buy cheap vps rather than questionable openvpn provider
    well its not like they all are not worth it,but most of them are not worth it.
    by using VPS cons is you need more time and knowledge to set it up, but continue reading.

  2. If your network block the openvpn service in level 2 than you are out of luck, but if they only block port list then you always can tweak your openvpn server to use tcp 80 / 443 as openvpn port
    this is why in point 1 i suggest using vps, although i have heard some good openvpn vendor already have this kind of configuration

I use Airvpn. Wish they had more server locations in Asia (especially in Japan) and South America but their config generator makes using the GL router brain dead easy. Just load the zip file and that’s it. There is literally nothing to configure you just scroll to the server you want and that’s it. I hate vpns that require that you install firmware/software.

any update here, having same issue, that purevpn (openvpn) is not working with 300m.
getting error:

OpenVPN 2.4.3 mips-openwrt-linux-gnu [SSL (OpenSSL)] [LZO] [LZ4] [EPOLL] [MH/PKTINFO] [AEAD] library versions: OpenSSL 1.0.2k 26 Jan 2017, LZO 2.09 WARNING: No server certificate verification method has been enabled. See How To Guide: Set Up & Configure OpenVPN Client/server VPN | OpenVPN for more info. Cannot open file key file ‘Wdc.key’: No such file or directory (errno=2) Exiting due to fatal error

I have loaded the zip file from purevpn site and it has cert and key file there with open vpn config files.


oh, forgot to add, running firmware 2.27

We had fixed this bug, you can try to upgrade to the testing firmware.

1 Like