Purevpn on mt300n

Hi - I have been very pleased with my mt300n which works well with Nordvpn but I need to change it to purevpn. When I load their Linux files (old) I get the following error when I try to connect.

OpenVpn is not started
Last log OpenVPN 2.4.3 mipsel-openwrt-linux-gnu [SSL (OpenSSL)] [LZO] [LZ4] [EPOLL] [MH/PKTINFO] [AEAD] library versions: OpenSSL 1.0.2g 1 Mar 2016, LZO 2.08 WARNING: No server certificate verification method has been enabled. See How To Guide: Set Up & Configure OpenVPN Client/server VPN | OpenVPN for more info. Cannot open file key file ‘Wdc.key’: No such file or directory (errno=2) Exiting due to fatal error

I should say I have loaded purevpn files along with Nordvpn so that I can choose between the two - perhaps I can only use one or the other at a time.

Could you please upgrade to v3.0 testing firmware? Which has fixed this bug. http://download.gl-inet.com/firmware/mt300n/testing/

Thanks kyson-lok - tried that and now my mt300n seems completely unusable. I tried 10s reset and although I seem to connect wifi with the default password I cannot display Web Admin on my Lan - unreachable.

A bit hasty there - it is still usable to provide wifi but unusable to provide VPN since no Admin is available.

Start from scratch with latest test firmware (don’t keep settings).

Thanks again - I now have progress to report.
I reluctantly loaded windows8 and followed the instructions right through with testing build 3. I was surprised (but also relieved) to end up with a completely different interface which I am navigating the setup of VPNs.
Delays were caused by Win8 updating the world (I only use it when I have to) and the fact that your instructions don’t apply to Linux Mint.