Really slow VPN speed on AXT800

Hello all I need some help.

I have the AXT800 and have set it up in my hotel in Repeater setting where I will be staying for the next 2 months.

The first test I did was to connect directly to the hotel wifi (not via the AXT800). The speed that I am getting on my phone is about 12mb/s. When I start up expressvpn on my phone directly, the speed is around the 12mb/s mark.

The second test I did was to set up the VPN on the AXT800 and connected my phone to the AXT800 wireless network. I re-ran the speed test and I am getting about 3mb/s. I tried nord vpn as well and also got the same speed.

I thought maybe it is a vpn speed issue. I disconnected the VPN on the AXT800 and re-ran the speed test and still got around the 3mb/s.

What am I doing wrong?

Are you connecting on the 5ghz band or 2.4ghz band? I’ve seen massive speed differences between the two.

Also, what speed are you getting on the AXT1800 without VPN? In other words, is it actually the VPN, or is it the router’s speed itself.

Hello jdub

I am connecting to the 5GHz band and the speed is the same on both with VPN connected and without

So not the VPN itself.

You might try connecting to 2.4 to see if it’s any better.

What firmware version are you on?

both 2.4 and 5 are giving me issues. I am on the latest firmware.

Have you tried the 4.1 beta release? The 4.1 (release 3) changelog is extensive and has enough in there that it might solve your issues. I experienced some similar problems when I was traveling a couple of months and ended up compiling my own firmware on a more-stock OpenWRT. I haven’t gotten a chance to test it out yet (will do that in a couple of weeks), but I’ll definitely have the MT1300 on hand as backup.

Do you have any details, e.g. channel, signal strength etc?

The firmware also could lock BSSID. In hotels there are many SSIDs. So you can lock to one that has better signal rather than let it choose automatically. Can you check?

BTW, upgrade to 4.1 firmware. Check out in