Recover from soft brick - Mango

Last night I happened to soft brick my Mango.

It is able to connect to the upstream router and offer dhcp and access to the internet.

Unable to access the standard and the UBOOT recovery GUI for configuration reset

A port scan reveals only port 53 is active.

Hoping there’s a way I can recover this little device without needing to crack it open an perhaps use a UART.

Googling has presented me with an option of using dnscat2 to potentially access the CLI. I’m having difficulties in installing the same on my PC.

Tried a 10 second press on the reset buton?

Did you try to follow the unbrick instruction briefly? Debrick via Uboot - GL.iNet Router Docs 4

Pretty weird, would be DNS then, which means the OS is still working.

Nah, won’t work - it’s for a complete different situation.

Thank you. I did try both of those a number of times.

Managed to gain access to the console via a UART connector and noticed a boot to failsafe mode (press the “f” key and press “enter” which presented me with a failsafe root login (no password needed).

I then noticed an error message related to a corrupt overlay and a few special commands listed. The first one I tried was “firstboot” followed by a “reboot”.

After reboot, I was presented with the welcome screen at I then proceeded to reset to factory defaults which caused the loss of the GUI again.

After a few more attempts of the above steps, I was able to regain GUI access, but it would hang with a wireless switched-off message.

Finally, after a few permutations of the 10 second reset followed by “firstboot” and three flashes reset and “firstboot” this last worked and I then preceeded to reflash the latest firmware successfully. This got rid of the gremlins and I now have a stable device restored to its former glory.