Remote access to home network using VPN server of GL-AR150


#1

Hello everybody!

I’d like to know if anyone has a good reference for me to learn how to use the GL-AR150 as a device (ethernet-)connected to my router at home, so that it creates a VPN server to allow me to access my network remotely.
That is, I want to access my home network from work, for example, through a VPN. I want to make sure I don’t need a (paid) VPN provider. I just want to leave the GL-AR150 continuously connected.

Thanks for the help,


#2

Because AR150 is behind your main router, you need to set up port forwarding in your main router and set up OpenVPN server or WireGuard Server.

For example, if your server runs at port 111, you need to port forward 111 from your main router’s 111 port the the router’s 111 port.

Then generate vpn config for your client and connect from Internet.


#3

Hey @alzhao, thanks for the quick reply.
Do you know anywhere I can read more about how to set up port forwarding for this specific implementation? I am a bit new to VPN and router configuration.
Thanks again,


#4

Since you need to set up port forwarding on your main router, you will need to find the brand and model of it, and find it on this site:

https://portforward.com/

They have a list of most routers and how to set up port forwarding on them. If that fails, check youtube or google for a guide.

For the VPN server itself, you can read here:
https://docs.gl-inet.com/en/3/app/openvpn/


#5

Thanks @Johnex. I think the VPN server configuration I can handle.
My only concern is understanding port forwarding. Is this only an enabled/disabled kind of configuration, or I’ll actually need to check on the GL-AR150 for some parameter and match it in the port forwarding settings of the router?
The “portfoward.com” link you’ve sent indeed has a page for my router, but it’s only a screenshot. From what I gather, I’ll need to check the IP address of GL-AR150 and just enable port forwarding for this IP in the router page. Is this correct?
Thanks again,


#6

You don’t need to do any port forwarding on your AR150, just the main router.

The OpenVPN default port is UDP 1194. So you want to add a new rule in your main router that will open port 1194 and route it to the IP of the AR150 and port 1194. You can also add a static IP to the AR150 in your main router if you wish. That will prevent the IP of the AR150 from changing in the future.


#7

Hmmm… That’s good, now I understand a bit better what @alzhao meant when mentioning port 111 for the router and port 111 again later. This means the list of actions I must do are:

  • on the router: set static IP for AR150
  • on the router: open port 1194 and direct it to the static IP I defined
  • on AR150: configure OpenVPN and save config file to use in my computers.

That should do it, right?


#8

Yup that is all you need to do :slight_smile:
If your router allows setting the port forward protocol, ie TCP, UDP or Both, keep that in mind when setting up the OpenVPN configuration, as you can use TCP or UDP and both configurations must match on that too.


#9

Perfect! Thanks a lot for the help! I’ve been reading on this all Sunday to no avail! Hehehe…
I’ll try to do it this weekend, if I need anymore help I’ll come back!
Many thanks, again!


#10

One last thing. Nowadays OpenVPN is quite old and clunky, I would recommend a new Wireguard configuration instead. There are clients for all the platforms, or you can use a second GL router as client. The configuration would be the same for wireguard, with the port forwarding requirement. Read up on that, since you will get much higher performance out of the AR150 with Wireguard vs OpenVPN.


#11

Oh, good to know! But I thought that the AR150 couldn’t use WireGuard because it requires a 3.xxx firmware…
If I’m mistaken and I actually have access to it, I’ll try to set up WireGuard instead.


#12

There is v3 firmware in the “testing” directory of the gl downloads page. Here is a direct link:

http://download.gl-inet.com.s3.amazonaws.com/firmware/ar150/testing/openwrt-ar150-3.022-0329.bin


#13

Ah, that’s awesome! Thank you very much!